#14331 closed defect (fixed)

TETRAEDGE: In-game tutorial not accessible

Reported by: Thunderforge Owned by: mduggan
Priority: high Component: Engine: Tetraedge
Version: Keywords:
Cc: Game: Syberia 1

Description

There is no way to access the in-game tutorial.

Expected Behavior

As stated when you start a new game:

You can review the help tutorial at any time in the options menu

This refers to the "Options" choice on the main menu.

Actual Behavior

On the main menu, clicking the Options menu brings up a ScummVM options menu, which does not provide access to any tutorial.

Versions Tested

  • ScummVM 2.8.0 Daily 2023-03-14
  • Syberia 1.0.2 macOS (GOG release)

Attachments (1)

iOS Options Menu.png (655.3 KB ) - added by Thunderforge 12 months ago.

Download all attachments as: .zip

Change History (5)

comment:1 by Thunderforge, 12 months ago

The Options menu also includes the Credits, but since those are not required to play and are not directly referenced by the game text, access to that is less important than the tutorial.

by Thunderforge, 12 months ago

Attachment: iOS Options Menu.png added

comment:2 by Thunderforge, 12 months ago

The original options menu is intended for controlling volume. As indicated in Discord discussion, the way to have in-game volume controls synchronize with ScummVM volume controls is as follows:

  • Setting volume in ConfMan when the game changes the volume (e.g. using in-game options)
  • Implementing Engine::syncSoundSettings() to pick up changes done from the ScummVM side (e.g. accessing the options dialog from the GMM)

comment:3 by mduggan, 11 months ago

This is done in c54b0457ed6. The original options screen now works with one small caveat that you can't separately control video volume as ScummVM does not have a separate channel for it. I just tied it to sfx volume.

It's possible to enhance it so that the game tracks video volume as a separate option, but I'll do that separately as the main part is done.

comment:4 by mduggan, 11 months ago

Owner: set to mduggan
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.