Opened 15 months ago

Closed 14 months ago

Last modified 14 months ago

#14328 closed defect (fixed)

TETRAEDGE: Quitting from the main menu of Syberia freezes ScummVM if "Return to the launcher" is set

Reported by: Thunderforge Owned by: criezy
Priority: high Component: Engine: Tetraedge
Version: Keywords: has-pull-request
Cc: Game: Syberia 1

Description (last modified by Thunderforge)

When quitting from the main menu in Syberia (the first game), ScummVM freezes.

Reproduction Steps

  1. In the ScummVM launcher, go to "Global Options" → "GUI" and then check "Return to the launcher when leaving the game"
  2. Launch Syberia in ScummVM
  3. On the main menu, click "Exit Game"
  4. On the prompt, "Do you really want to quit?", click "OK"

The music will continue but ScummVM will freeze.

Versions Tested

  • ScummVM 2.8.0 Daily 2023-03-14 macOS x64
  • Syberia 1.0.2 macOS (GOG release)

Change History (11)

comment:1 by Thunderforge, 15 months ago

Description: modified (diff)

comment:2 by Thunderforge, 15 months ago

Summary: TETRAEDGE: Quitting from the main menu freezes ScummVMTETRAEDGE: Quitting from the main menu of Syberia freezes ScummVM

comment:3 by Thunderforge, 15 months ago

Description: modified (diff)

comment:4 by Thunderforge, 15 months ago

Priority: normalhigh

comment:5 by mduggan, 15 months ago

I can't reproduce this (or the corresponding Syberia 2 lockup #14329) on macOS - I even ran with address sanitizer to make sure nothing seems wrong. I wonder if there is a problem unique to Windows builds?

comment:6 by Thunderforge, 14 months ago

I'm running on the macOS x64 builds, not the Windows builds. It's still happening consistently in the latest dailies. Let me know how I can help resolve it.

comment:7 by Thunderforge, 14 months ago

I found out that this only happens if you go to the ScummVM Launcher -> Global Options -> GUI and then check "Return to the launcher when leaving the game". If that option is unchecked, there is no freeze.

comment:8 by Thunderforge, 14 months ago

Description: modified (diff)
Summary: TETRAEDGE: Quitting from the main menu of Syberia freezes ScummVMTETRAEDGE: Quitting from the main menu of Syberia freezes ScummVM if "Return to the launcher" is set

comment:9 by criezy, 14 months ago

Keywords: has-pull-request added

I created a pull request that fixes this issue.
It also fixes a separate issue when the Ask for confirmation on exit option is toggled on in the ScummVM options.

https://github.com/scummvm/scummvm/pull/4827

comment:10 by criezy, 14 months ago

Owner: set to criezy
Resolution: fixed
Status: newclosed

The pull request has already been merged, so the issue should be fixed now.

comment:11 by Thunderforge, 14 months ago

I've confirmed that the fix works. Thank you!

Note: See TracTickets for help on using tickets.