#14309 closed defect (outdated)

GFX: Cursor: Regression - Cursor broken in certain games

Reported by: raziel- Owned by: raziel-
Priority: normal Component: Graphics
Version: Keywords: (hardware/system?) cursor, filter graphics
Cc: Game:

Description

ScummVM 2.8.0git (Mar 8 2023 08:13:58)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 Theora AAC A/52 FreeType2 FriBiDi JPEG PNG GIF cloud (servers, local) ENet TinyGL OpenGL (with shaders)

Setting the "Graphics Mode" to "OpenGL", the size to "1x" makes some games from some engines break it's cursor display.

It looks like as if the cursor graphics are picking up some random data from before (or load from the wrong place).

Engines i checked (but not all games affected) are:
AGI
AGOS
TsAGE
Toltecs

See attached screenshots

The 13th Disciple (v1.01) (DOS/English)
The Feeble Files (2CD Windows English)

These engines only display a broken cursor if one skips the intro and the "skip intro" dialogue shows, the game cursors itself are fine.
Blue Force (CD DOS English)
Ringworld 1 Rvenge of the Patriarch (CD DOS English)
3 Skulls of the Toltecs (DOS English)

AmigaOS4 - SDL2 - PPC - BE
gcc (adtools build 11.3.0) 11.3.0

This might or might not be related to #14308

Change History (13)

comment:1 by raziel-, 14 months ago

Keywords: (hardware/system?) added

Found another one (Nippon Safes) and i think i also know the reason (but no solution).

As soon as a game doesn't use it's own cursor graphics (like in Simon 2 and Feeble Files) but rather use the system provided one (or hardware cursor?) it will glitch out.

So, it's not an engine thing, but a system cursor thing.

by raziel-, 14 months ago

comment:2 by lephilousophe, 12 months ago

Looks like a bug on the platform (maybe ogles2).

comment:3 by raziel-, 12 months ago

I did some more tests and it also seems to be dependant on the scaler used
(x = broken | v = working)

Scaler1x2x3x4x5x
Normal xvvvv
HQ x x
Edge x x
AdvMame vv x
SAI x
SuperSAI x
SuperEagle x
PM x
DotMatrix x
TV x

Does it make that any clearer?

comment:4 by lephilousophe, 12 months ago

I don't think so. :|
This is even more obscure.

Did you try working cases only once or several times?
I wonder if you got luck.

BTW, is 2.7 build working?
Maybe you will have to bisect the error.

comment:5 by raziel-, 12 months ago

@lephilousophe

I went from the first non-working case, then returned to launcher, chose another scaler and restarted the game (13th disciple), then re-did the steps.
All in one session, but it doesn't matter, because I found out about the other scaler issues when I did a fresh run.

I did try them multiple times, too.

There is another issue I found...with external scalers...I know that eagle/supereagle works, but when i test those pointer glitches sometimes the test screen for the external scaler isn't displayed albeit working...so more strange stuff happening.

I'll try to do a manual bisect and the 2.7 test when i'm back home...thanks for the pointer :-)

I also hope the ogles2 maintainer will comment, here's hoping.

comment:6 by raziel-, 12 months ago

Owner: set to raziel-
Resolution: outdated
Status: newclosed

Fixed in local ogles2 v3.4

Sorry for the noise

Note: See TracTickets for help on using tickets.