Opened 12 months ago

Last modified 11 months ago

#14301 new defect

TETRAEDGE: Hotspot to Leave Notary's Office Does Not Work

Reported by: digitall Owned by:
Priority: low Component: Engine: Tetraedge
Version: Keywords:
Cc: Game: Syberia 1

Description

As per title, the hotspot to exit the notary's office after getting Anna's letter does not work, thus the game is stuck at that point.

Have replicated from a new game and repeated the same issue. It may be related to the sequence of hotspots I do, but the faulty state can be replicated from loading a savegame, so am attaching mine for investigation.

Attachments (3)

syberia-mac.000 (54.7 KB ) - added by digitall 12 months ago.
syberia-mac.001 (53.8 KB ) - added by digitall 12 months ago.
Screenshot 2023-03-09 at 10.57.51.2.png (443.2 KB ) - added by mduggan 12 months ago.

Download all attachments as: .zip

Change History (9)

by digitall, 12 months ago

Attachment: syberia-mac.000 added

by digitall, 12 months ago

Attachment: syberia-mac.001 added

comment:1 by digitall, 12 months ago

This was replicated on 08747054cdef79ce45ba3b008ccc1d794e442a72 running on Linux x86_64 built from master.

comment:2 by digitall, 12 months ago

I do get the following debug messages when clicking / hovering over the hotspot:
loadAndCheckFourCC: Look for TEZ0, got TEAN
[TeLuaThread::Execute1] Function: "OnButtonUp" does not exist

comment:3 by mduggan, 12 months ago

I loaded the 001 savegame and was able to leave the office. One thing though, the marker is slightly offset from the actual click area - you have to click somewhere above the marker, more around the door.

If that still doesn't work, can you attach a screenshot after enabling TETRAEDGE_DEBUG_PATHFINDING in game/in_game_scene.cpp? It should show the actual click zone around the door like in this screenshot:

Last edited 12 months ago by mduggan (previous) (diff)

comment:4 by digitall, 12 months ago

@mduggan: Agh! Yes, that does work if I click on the door. I thought I had tried that, but evidently not.

The real issue then is that hotspot marker is pretty misleading / misaligned. However, if that is from the original engine, then you can close this as WONTFIX.

I would suggest maybe a room specific hack to extend the door hotspot, but that would need some testing to make sure it didn't cause issues?

comment:5 by mduggan, 12 months ago

Priority: normallow

Thanks for checking! I should double-check the location, but I think it's "correct" as much as it matches the original.

I agree it might be good to have a feature to correct the locations of some of them too, there are others which are quite offset like this. I'll try to think of the best way to make a feature like that.

comment:6 by antoniou79, 11 months ago

Summary: SYBERIA: Hotspot to Leave Notary's Office Does Not WorkTETRAEDGE: Hotspot to Leave Notary's Office Does Not Work
Note: See TracTickets for help on using tickets.