#14291 closed defect (invalid)

the Enable All Engines configure flag does not enable starship titanic by default

Reported by: Paolo86cripple Owned by: digitall
Priority: normal Component: Common
Version: Keywords:
Cc: Game:

Description

Even with the --enable-engine flag the engine is still disabled

Change History (4)

comment:1 by tag2015, 17 months ago

Priority: highnormal

Check configure output, are you sure you don't have missing dependencies?

comment:2 by Paolo86cripple, 17 months ago

You're right, the output goes like this ARNING: Disabling engine Starship Titanic because the following dependencies are unmet: MAD. Sorry. How do I solve it?

comment:3 by tag2015, 17 months ago

You simply need to install libmad using you distro's package manager, if you are on linux

comment:4 by digitall, 17 months ago

Owner: set to digitall
Resolution: invalid
Status: newclosed

@Paolo86cripple: From your earlier bugs, I am aware that you are using Arch Linux.

See here for a general guide to compiling ScummVM on Linux platforms, including Arch specific commands for dependencies:
https://wiki.scummvm.org/index.php?title=Compiling_ScummVM/GCC#Arch_Linux-based_distributions

Closing this as invalid since missing dependencies are not a bug.

Note: See TracTickets for help on using tickets.