#14276 closed defect (fixed)

Broken Sword 1 Polish doesn't work on 2.7.0

Reported by: szczuru Owned by: sev-
Priority: normal Component: Engine: Sword1
Version: Keywords: unknown-game
Cc: szczuru Game: Broken Sword 1

Description

Works ok on 2.6.1 and earlier versions. Scummvm doesn't shows "unknown game" window (just "none game detected")

crcs:

    Plik: GENERAL.CLU
  CRC-32: 3f48b8fc
     MD5: 39a14f0f1859307e3167457a34babe4f
   SHA-1: 2fe7b9d593c4edf54e64c294becb1c219704fb8b
 SHA-256: 0019ab0e6299d1e68ad113dfc9ed265a89dce762ca57ff8e9b005d0ccad87cbb
 SHA-512: 215a8aab2a994e33e982abe41cc71d4d3e1270ebe70e5d1906363e9222e4090a646e9987563bd198aef12659275604c8a5087cc80241ffcdb201812a53b0d87d

    Plik: TEXT.CLU
  CRC-32: d030a80f
     MD5: a151503dbd85655129d29f42bb52e808
   SHA-1: 57cb7780fea602d5fec5e93d30f5a786711e84f1
 SHA-256: 7e99683b568bb4416a0a7c138d09268dd5b847b7ca8c1a3e0c2857a46ec20035
 SHA-512: 944ca6d855fd3cad0314bb3b8636ec5d6df16a5686a9e08d054ba83986ecf32bd2d89256180136d81878aff5494786217a04b4feb6cb501adda549854e39d551
    Plik: PARIS1.CLU
  CRC-32: f82f570c
     MD5: 6c85a3dc5c3f7b4a3e11ac22cb183cc2
   SHA-1: f85984d7c6942e08df3ff1d5c3c62c4cd67d1dc4
 SHA-256: 0fc7314cc5b7f9e6e32a87444922a2854d5661b8121c4b6a6c4dfe7ca80a311a
 SHA-512: 83bbf42953c063dbaa98700b4894f39473f4e264f7a99bc509f596e810e3eba0a337a8d6d331d3a5fbbe1ee96bce242b4c9cb58382a0512ee47d9e28662e1546


Attachments (1)

tree.txt (5.6 KB ) - added by szczuru 12 months ago.

Download all attachments as: .zip

Change History (8)

comment:1 by sev-, 12 months ago

Could you please provide the recursive directory list?

by szczuru, 12 months ago

Attachment: tree.txt added

comment:2 by szczuru, 12 months ago

Attached file list.

comment:3 by szczuru, 12 months ago

Hi you posted commit with other/wrong md5:

		"sword1",
		"English speech and DXA cutscenes",
		AD_ENTRY4s("clusters/scripts.clu",  "72b10193714e8c6e4daca51791c0db0c", 1087240,
				   "clusters/swordres.rif", "88c0793a4fa908083b00f6677c545f78", 58916,
				   "clusters/text.clu",     "7d9e47533fde5333dc310bfd73eaeb5c", 2666944,
				   "intro.dxa",             nullptr, -1),
		Common::PL_POL,
		Common::kPlatformWindows,
		ADGF_NO_FLAGS,
		GUIO0()

My files (md5 of 5000 bytes, size in bytes)
TEXT.CLU B9E7B3E342569BE68738E4681F2ADEFF, 3164267
SWORDRES.RIF 04A41FC5783D18A8958D41AA9A3823AF, 59788
SCRIPTS.CLU 72B10193714E8C6E4DACA51791C0DB0C, 1088292

Also on 2.6.1 Game works with clu files in root directory, but in latest daily build game isn't detected if clu files are not in clusters directory - but still even if they are in that dir - scummvm detects my version as unknown version of Sword2:

The game in 'BS1\' seems to be an unknown game variant.

Please report the following data to the ScummVM team at https://bugs.scummvm.org/ along with the name of the game you tried to add and its version, language, etc.:

Matched game IDs for the sword1 engine: sword1-win

  {"clusters/scripts.clu", 0, "72b10193714e8c6e4daca51791c0db0c", 1088292},
  {"clusters/swordres.rif", 0, "04a41fc5783d18a8958d41aa9a3823af", 59788},
  {"clusters/text.clu", 0, "b9e7b3e342569be68738e4681f2adeff", 3164267},
  {"video/intro.dxa", 0, "e27cd33593c08b66e8d20fbc40938789", 7420364},

Last edited 12 months ago by szczuru (previous) (diff)

comment:4 by sev-, 12 months ago

Ah, thank you for checking. I fixed the md5s. Please retest with tomorrow's build.

comment:5 by lephilousophe, 12 months ago

Owner: set to sev-
Resolution: fixed
Status: newpending

comment:6 by szczuru, 12 months ago

I can confirm game is now detected properly :) Thank you.

comment:7 by sev-, 12 months ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.