#14275 closed defect (fixed)

PORT: 1st gen. Miyoo (Bittboy) Crash on Screen Shake

Reported by: salvacam Owned by: salvacam
Priority: normal Component: Ports
Version: Keywords:
Cc: Game: Day of the Tentacle

Description

I get an error on Day of tentacle.
Vibrating the image closes the emulator.
But I don't see anything in the log.

Link to video
https://streamable.com/vnrsl6

Log:

[1970-01-01 01:48:15] ScummVM 2.7.0 (Feb 26 2023 02:56:01)
[1970-01-01 01:48:15] TAINTED Tremor MP3 RGB zLib Theora FreeType2 FriBiDi JPEG PNG GIF VirtualKeyboard cloud (servers, local) TinyGL
[1970-01-01 01:48:15] --- Log opened.
[1970-01-01 01:48:16] Virtual keyboard pack 'vkeybd_default' loaded successfully
[1970-01-01 01:48:22] WARNING: SearchSet::add: archive 'engine-data' already present!

Change History (4)

comment:1 by digitall, 12 months ago

Component: --Unset--Ports
Summary: 1st gen. Miyoo (Bittboy) Close with vibrating imagePORT: 1st gen. Miyoo (Bittboy) Crash on Screen Shake

I don't think the port to the RG351P devices is from the ScummVM download page i.e. thirdparty ports may have issues.

However, if you are compiling from code, try the latest v2.8.0 master branch code since I suspect this was caused by the issues with Screen shake on SDL1.2 ports i.e. fixed by https://github.com/scummvm/scummvm/pull/4754 and https://github.com/scummvm/scummvm/pull/4780 which were merged recently.

Will set this to pending on feedback if it is fixed. If no feedback is received in 2 weeks, this bug will be closed assuming that it is fixed.

comment:2 by digitall, 12 months ago

Owner: set to digitall
Resolution: fixed
Status: newpending

comment:3 by salvacam, 12 months ago

this ticket can be considered resolved.
with this PR it is solved.
https://github.com/scummvm/scummvm/pull/4754

Yesterday I compiled it and it does not give the error

comment:4 by salvacam, 12 months ago

Owner: changed from digitall to salvacam
Status: pendingclosed
Note: See TracTickets for help on using tickets.