Opened 15 months ago

Closed 4 weeks ago

#14257 closed defect (fixed)

GLK: SCOTT: fatal() and GlkExit() do return

Reported by: angstsmurf Owned by: hari01584
Priority: normal Component: Engine: GLK: Scott
Version: Keywords:
Cc: Game:

Description

The Scott::fatal() method is supposed to print an error message and then exit, but seems to return after calling GlkExit(), which is also not supposed to return.

This causes an assert: "Assertion failed: (idx < _size), function operator[], file array.h, line 234" after showing the "Unsupported game! [press any key to exit]" message when trying to run an unsupported game.

The expected behaviour would be to either return to the launcher or exit ScummVM cleanly.

Change History (8)

comment:1 by hari01584, 15 months ago

How to reproduce this? What kind of games/files make scumm give unsupported game, please elaborate.

comment:2 by angstsmurf, 15 months ago

I seems that pretty much any file you give a .saga extension will be detected by ScummVM as "Scott Adams IF Game".

comment:4 by angstsmurf, 15 months ago

Excellent!

Perhaps we should file a separate bug report or feature request about the fact that the detection code is too permissive in assuming that any .saga file is a valid Scott Adams game.

comment:5 by hari01584, 15 months ago

Looked into the code, and it really has no checking for .saga, but not sure if this is by design(intentional) or actually a bug.

comment:6 by tag2015, 5 weeks ago

Now that the PR has been merged I suppose this bugreport can be closed?

comment:7 by angstsmurf, 4 weeks ago

Yes, seems to be working as intended now. Running an unsupported .saga game will now print an "Unsupported Game!" message and then exit ScummVM.

comment:8 by tag2015, 4 weeks ago

Owner: set to hari01584
Resolution: fixed
Status: newclosed

Thanks for the reply! closing as fixed

Note: See TracTickets for help on using tickets.