Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1424 closed defect (fixed)

FT: Ben stops talking mid-scentence @ the gorge

Reported by: SF/themmaster Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

ScummVM 0.5.7cvs (Jan 27 2004 00:55:14)
Language : English
Version : Talkie
Platform : Linux GCC-3.3

When reading the lower-left notice about the
illegalness of jumping the gorge, ben stops talking
mid-scentence. Text still there, no speach.

Ticket imported from: #885490. Ticket imported from: bugs/1424.

Attachments (1)

ft.s21 (7.1 KB ) - added by sev- 16 years ago.
FT V2 savefile with the bug

Download all attachments as: .zip

Change History (11)

comment:1 by fingolfin, 16 years ago

Summary: Ben stops talking mid-scentence @ the gorgeFT: Ben stops talking mid-scentence @ the gorge

comment:2 by sev-, 16 years ago

Yes, this is a bug. Original plays voice to the end.

I attached savefile, but for v2 of the game (md5 starts with
60ba), although it works with v1 but not until you try to
see the inventory.

by sev-, 16 years ago

Attachment: ft.s21 added

FT V2 savefile with the bug

comment:3 by fingolfin, 16 years ago

sev: I think you meant to say: "It works with v1, as long as you do not
try to open the inventory (which will cause a crash)" ? :-)

This could be a script problem, or a problem in iMuseDigital... assigning
to aquadran to ensure he's aware of this issue (but Pawel, feel free to
unassign this again).

comment:4 by fingolfin, 16 years ago

Owner: set to aquadran

comment:5 by aquadran, 16 years ago

i checked that some time ago. speech in FT is from sou file,
if i right remember, imuse got truncated sample from source
data, maybe something is wrong with sou code.

comment:6 by fingolfin, 16 years ago

Owner: changed from aquadran to SF/ender

comment:7 by fingolfin, 16 years ago

The problem is caused by the VOC data used in the Full Throttle
MONSTER.SOU may contain multiple type 1 blocks, but we only handled
the first one. I fixed the code in CVS to playback all the VOC sound data,
not just the first part. So if you are using the uncompressed monster.sou,
everything should be fine now.

However, 'extract' is also affected by the bug - it encodes only the first
data block found in the VOC data. Hence all compressed audio files
generated by our 'extract' tool is truncated. We need to fix that, then tell
everybody to re-encode their audio data.

Assigning to Ender to ensure he's aware of the issue :-). Feel free to
dump it back to the pool or assign it to me (I'll look into fixing 'extract'
after I slept a bit).

comment:8 by fingolfin, 16 years ago

Status: newclosed

comment:9 by fingolfin, 16 years ago

Fixed the 'extract' tool, and also backported the fix in ScummVM to the
0.6.0 branch. We probably should tell our users to re-encode their FT
monster.sou files when we release this.

comment:10 by fingolfin, 16 years ago

Owner: changed from SF/ender to fingolfin
Resolution: fixed
Note: See TracTickets for help on using tickets.