Opened 13 months ago

Closed 9 months ago

#14081 closed defect (duplicate)

ITE: Inherit the Earth Amiga version crashing on macOS x64

Reported by: internetzel Owned by: dwatteau
Priority: high Component: Engine: SAGA
Version: Keywords:
Cc: Game: Inherit the Earth

Description

The upcoming 2.7.0 (macosx-x86_64-stable-9ba4a77a) nearly always crashes during the intro of Inherit the Earth AGA CD Amiga German (Amiga versions new to be supported), at different points during the intro, but always when skipping the story at the beginning.
Then sometimes ScummVM enters the debugger saying some resource file couldn't be loaded and other times it directly crashes (crash report attached).
The OS is macOS 11.7.3 .

Attachments (1)

scummvm_crash.txt (80.4 KB ) - added by internetzel 13 months ago.

Download all attachments as: .zip

Change History (4)

by internetzel, 13 months ago

Attachment: scummvm_crash.txt added

comment:1 by lotharsm, 13 months ago

Priority: normalhigh

comment:2 by lotharsm, 13 months ago

Summary: Inherit the Earth Amiga version crashing on macOS x64ITE: Inherit the Earth Amiga version crashing on macOS x64

comment:3 by dwatteau, 9 months ago

Owner: set to dwatteau
Resolution: duplicate
Status: newclosed

I can reproduce this on Linux, Windows and on OSX PPC -- it's random (and appears to be related to FSDirectory::createReadStreamForMember) but some systems appear to be more likely to hit the issue than others?

I'm closing this as a duplicate to ticket #14334 though, since it appears to be the same problem, and that other ticket has more technical details. Thanks for reporting this, though!

Note: See TracTickets for help on using tickets.