Opened 3 weeks ago

Closed 2 weeks ago

#14057 closed defect (fixed)

AGS: Shaders cause black screen in AGS games

Reported by: tag2015 Owned by: lephilousophe
Priority: high Component: Engine: AGS
Version: Keywords: shaders, ags, opengl
Cc: Game:

Description

Any shader (enabled in global options or in game override) cause the screen for AGS games to appear blank.
In some cases, the correct image appears briefly and then turns blank, in other cases nothing appears at all.
It should be noted that sound and hotspots work normally, the issue is only related to the graphics.

The only solution currently is to manually set the shader to "none" or set the graphics mode to SDL, in each AGS game override.

ScummVM 2.8.0git7327-ga2242d8fa1b on Win10

Change History (3)

comment:1 by tag2015, 3 weeks ago

Priority: normalhigh

comment:2 by lephilousophe, 3 weeks ago

Owner: set to lephilousophe
Resolution: fixed
Status: newpending

comment:3 by lephilousophe, 2 weeks ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.