#14051 closed defect (fixed)

SCUMM: MI1: Can't close using Alt-F4

Reported by: lephilousophe Owned by: lephilousophe
Priority: high Component: Engine: SCUMM
Version: Keywords:
Cc: Game: Monkey Island 1

Description

Using the demo from ScummVM website on a Linux / SDL2 backend.
Pressing Alt-F4 does nothing instead of displaying the quit confirmation dialog of the original UI.
This happens after skipping all the intro videos.
If you do the key combination plenty of time you finally get the dialog displayed.
I think it has to do with when the key is sampled as the framerate is quite low.

Change History (3)

comment:1 by AndywinXp, 13 months ago

Thanks, does this happen with other key combinations which should display the prompt, like CTRL-C?

comment:2 by AndywinXp, 13 months ago

Okay, after trying my Windows laptop, my Linux VM and my Mac, I can say that I really can't reproduce this... do you have any other desktop devices that you could try at your disposal?

comment:3 by AndywinXp, 13 months ago

Owner: set to lephilousophe
Resolution: fixed
Status: newclosed

Thanks for the fix! Closing

Note: See TracTickets for help on using tickets.