Opened 16 years ago

Closed 16 years ago

#1404 closed defect (fixed)

DIG: Picking up metal plate: assertion failed

Reported by: SF/pkirlin Owned by: aquadran
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

I'm running the latest CVS Windows snapshot of
ScummVM, ScummVM 0.5.7cvs (Jan 21 2004 11:05:57)

This bug occurs in the Dig, regular English CD version
(not from Archives III). It occurs near the end, when
Boston and Maggie have revealed the hidden island from
the "strange field" and enter it. They see the fourth
metal plate. When Boston tries to pick it up, the game
crashes. The entire output is below.

-----
F:\ScummVM>scummvm.exe
Looking for dig
Trying to start game 'The Dig'
d8323015ecb8b10bf53474f6e6b0ae33 dig.la0
Match found in database: target dig, language (null),
platform (null)
Registered debugger
Assertion failed: num != -1, file
scumm/imuse_digi/dimuse_music.cpp, line 98

abnormal program termination
-----

I put this in the music category since from the filename,
it appears it's some sort of problem with the music
system.

A save game is attached right before this happens.

Thanks all; keep up the great work!

Ticket imported from: #881141. Ticket imported from: bugs/1404.

Attachments (1)

dig.s05 (22.6 KB ) - added by SF/pkirlin 16 years ago.
savegame to reproduce crash (click on metal plate)

Download all attachments as: .zip

Change History (5)

by SF/pkirlin, 16 years ago

Attachment: dig.s05 added

savegame to reproduce crash (click on metal plate)

comment:1 by SF/pkirlin, 16 years ago

Summary: Picking up metal plate: assertion failedDIG: Picking up metal plate: assertion failed

comment:2 by Kirben, 16 years ago

Owner: set to aquadran

comment:3 by SF/ender, 16 years ago

Assigned to aquadran. Will people PLEASE remember to put
comments in when they assign things to anybody but themselves, at
least stating why :)

comment:4 by aquadran, 16 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.