#14038 closed defect (fixed)

DREAMWEB: Can't progress past Sartain

Reported by: plancsar Owned by: tag2015
Priority: normal Component: Engine: Dreamweb
Version: Keywords:
Cc: Game: Dreamweb

Description

At the end of the Sartain Industries part Ryan is teleported away, then the game hangs indefinitely. Notably, a second immobile Ryan appears in the scene. Ryan's profile on the left blinks, and I can move the cursor, but otherwise the interface is locked.

Attachments (3)

DreamwebBug1.jpg (195.8 KB ) - added by plancsar 13 months ago.
DreamwebBug2.jpg (189.5 KB ) - added by plancsar 13 months ago.
DREAMWEB.D03 (13.5 KB ) - added by plancsar 13 months ago.

Download all attachments as: .zip

Change History (10)

by plancsar, 13 months ago

Attachment: DreamwebBug1.jpg added

by plancsar, 13 months ago

Attachment: DreamwebBug2.jpg added

by plancsar, 13 months ago

Attachment: DREAMWEB.D03 added

comment:1 by tag2015, 13 months ago

This is strange, I can't reproduce the bug using your save. After reaching the hovercar I could open the inventory and use the gun normally.
Which version of scummvm are you using? Also, did you obtain the game from our "freeware games" page or somewhere else?

in reply to:  1 comment:2 by plancsar, 13 months ago

Thank you; I'm using ScummVM 2.6.1 Release. I got the game from the Freeware page; I tried with the UK, US and Italian versions, they all show the same error.

Replying to tag2015:

This is strange, I can't reproduce the bug using your save. After reaching the hovercar I could open the inventory and use the gun normally.
Which version of scummvm are you using? Also, did you obtain the game from our "freeware games" page or somewhere else?

comment:3 by tag2015, 13 months ago

Could you try a daily build and see if you can proceed?
https://buildbot.scummvm.org/#/dailybuilds

Also, it would help if you could tell us your platform (Windows, Android, etc.)

comment:4 by plancsar, 12 months ago

I found I can trigger two behaviours:

  • if I step into the helipad, then 'use' the gun, the scene proceeds as expected;
  • if I 'use' the gun, then step into the helipad, the Ryan clone shows up and the scene hangs.

In other words, it's possible to 'use' the gun while on the rooftop, or even the staircase, but it seems that the game doesn't know how to handle that.

The behaviour shows up in both ScummVM 2.6.1 stable and a daily build, on both Win 11 and macOS 10.14.6.

comment:5 by tag2015, 12 months ago

Thanks, now I see the issue. I have a fix but I'll cross-check with dosbox first to see the original behavior.

comment:6 by tag2015, 12 months ago

Confirmed that this is an original bug, happens identically in DOSBox.
Made a fix so that the gun can be used only when the character is next to the hovercar (as it's supposed to be).
Fix will be in tomorrow's development daily build

comment:7 by tag2015, 12 months ago

Owner: set to tag2015
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.