Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#14027 closed defect (fixed)

SCUMM: Problems with subtitles in DIG

Reported by: GermanTribun Owned by: AndywinXp
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game: The Dig

Description (last modified by GermanTribun)

System: Windows 10 x64
ScummVM: Newest 2.7.0git
Version: German CD

For some reason the subtitle controls in at least the German version of The Dig are kind of unreliable. For some reason the game, if the global override is on, always jumps back to having speech and subtitles. Even more bizarre, when deactivating the override (I have global on speech only), then subtitles are still shown in the intro, but not the game itself.

My suspicion is that it stems from an orginal interpreter goof, in that the text in the intro telling the player about the Berneo observatory for some reason got linked to the subtitles, even though in the English version it was independent of it and even appeared in speech only (and didn't appear at all in the German version under DOS if text was off). This seems to confuse ScummVM, so maybe the location description can be altered to work like in the English version.

Btw., the alignment of the location description also is off. It should be centered.

Attachments (1)

scummvm-dig-de-00000.png (67.3 KB ) - added by GermanTribun 17 months ago.

Download all attachments as: .zip

Change History (7)

by GermanTribun, 17 months ago

Attachment: scummvm-dig-de-00000.png added

comment:1 by GermanTribun, 17 months ago

Description: modified (diff)

comment:2 by AndywinXp, 17 months ago

For some reason the subtitle controls in at least the German version of The Dig are kind of unreliable. For some reason the game, if the global override is on, always jumps back to having speech and subtitles. Even more bizarre, when deactivating the override (I have global on speech only), then subtitles are still shown in the intro, but not the game itself.

Thanks, I think that is happening because I'm not syncing the original GUI voice mode flags with the ScummVM ones. I will investigate and provide a fix.

My suspicion is that it stems from an orginal interpreter goof, in that the text in the intro telling the player about the Berneo observatory for some reason got linked to the subtitles, even though in the English version it was independent of it and even appeared in speech only (and didn't appear at all in the German version under DOS if text was off). This seems to confuse ScummVM, so maybe the location description can be altered to work like in the English version.

There are certain subtitles which are always forced on (e.g. the location description), but the german version on the contrary is the only one which forgot to flag that text as always on. So your observation is correct, but it's not an interpreter goof: the issue is in the data files of the german version, so if ever there can be a patch for it, it has to be on the video file itself.

Btw., the alignment of the location description also is off. It should be centered.

On a pretty design level? Sure, it should :-) But the reality of it is that the position of the text is decided by the video file itself, so on our implementation we're doing no more and no less than what the interpreter did (I confirmed on DosBox that the text is positioned like that on all the versions I have of this game). So, again, an hypothetical patch should be applied to the video file instead.

comment:3 by GermanTribun, 17 months ago

I had no idea the subtitles in the videos were bound to the video file itself. I always thought the text somehow interacted with it instead.

comment:4 by AndywinXp, 17 months ago

Owner: set to AndywinXp
Resolution: fixed
Status: newclosed

Fixed in master.

comment:5 by GermanTribun, 17 months ago

Was it also fixed in the newest daily? In that one I still have the problem. The only way to get rid of the subtitles in the intro is to open the save panel and turn subtitles first on and then off.

comment:6 by AndywinXp, 17 months ago

The daily comes from the master and is updated once a day, so just wait :-)

Note: See TracTickets for help on using tickets.