Opened 18 years ago

Closed 18 years ago

#140 closed defect (fixed)

Indy4 - 'moonwalk' bug in Iceland

Reported by: SF/indy4 Owned by: SF/ender
Priority: blocker Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

Latest Windows version of the software, running under
Windows XP (same as my 'Tikal' bug).

In Iceland, I entered the cave and Indy stopped in
the entrance and just kept 'moonwalking', ie walking
movement taking place but going nowhere fast!
Talking, etc worked fine. When the 'conversation' had
ended Indy stopped walking, but minus his head! On
moving Indy his head reappeared. I have uploaded a
saved game with him doing the moonwalk. :)

Phil

Ticket imported from: #540647. Ticket imported from: bugs/140.

Attachments (1)

atlantis.s04 (45.0 KB ) - added by SF/indy4 18 years ago.
Indy4 - Moonwalking bug

Download all attachments as: .zip

Change History (12)

by SF/indy4, 18 years ago

Attachment: atlantis.s04 added

Indy4 - Moonwalking bug

comment:1 by (none), 18 years ago

Logged In: NO

Same bug under gnu/linux using CVS built on 7th april.

But when i leave the cave and re-enter it, indy walks
flawlessly.

J-f

comment:2 by SF/ender, 18 years ago

Owner: set to SF/ender
Priority: normalhigh

comment:3 by SF/ender, 18 years ago

Uhhh, this one looks REALLY odd - I'm not sure if it'll be
very easy to fix, but I'll give it a try :)

comment:4 by SF/ender, 18 years ago

Ok, this is caused by o5_walkActorTo - somehow the walking
stuff just gives up.

Debug when standing in the cave entry and TALK'ing to
Heimdall:

walk actor 1 from (267,53) to (118, 96)
walk actor 2 from (260,41) to (170, 100)
walk actor 1 from (267,53) to (91, 70)

(Actor 1: EGO - indy. Actor 2 - Sophia)

Obviously Indy can't navigate from 267, 53 to 91.70 with
the current code. Not sure why, still investigating.

comment:5 by SF/oli_k, 18 years ago

When I use "talk" to Heimdal, Indy makes moonwalking on my
PC, too. But he already looses his head when talking.

In the build from April 4th everything's fine.

I'm using Windows XP, too.

-Oli

comment:6 by SF/ender, 18 years ago

Priority: highblocker

comment:7 by SF/ender, 18 years ago

I'll do a CVS diff between April 4th and current to see
what changed.. hopefully this one will be easy to find now
I know when it -stopped- working :)

comment:8 by SF/ender, 18 years ago

Component: Engine: SCUMM
Game: Indiana Jones 4

comment:9 by SF/ender, 18 years ago

Changing group/catagory to match new bug guidelines.

comment:10 by SF/ender, 18 years ago

Resolution: fixed
Status: newclosed

comment:11 by SF/ender, 18 years ago

Fixed now.

Note: See TracTickets for help on using tickets.