Opened 16 years ago

Closed 16 years ago

Last modified 11 months ago

#1398 closed defect (fixed)

COMI: Subtitle problems in Act II

Reported by: SF/shirasuwanum Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: Monkey Island 3

Description

In Act II of COMI with scripting enabled, just past the
lemonade stand, no scripting occurs, or is fragmentary.
This applies to both scripting of speech and script that
identifies objects. In the case of speech, either no
script or a script fragment will be displayed. In the case
of object identification, placing the cursor over a "hot"
object (chicken cage, epicac plant, intercom, etc.):
should cause script to appear that identifies the object;
but there's no script. This problem occurs elsewhere in
COMI, but is particularly bad in this location.

To reproduce: Enable scripting. In Act II, make Guy
move past the lemonade stand. Place the cursor over
various objects. No script will appear. I've attached a
save file.

This occurred on Win32 version 0.5.7.0, using the daily
snapshot of January 19, 2004 4:53 PM. Talkie version
of the game in English.

Ticket imported from: #880418. Ticket imported from: bugs/1398.

Attachments (1)

comi.s01 (54.8 KB ) - added by SF/shirasuwanum 16 years ago.
Save of Guy near lemonade stand

Download all attachments as: .zip

Change History (9)

by SF/shirasuwanum, 16 years ago

Attachment: comi.s01 added

Save of Guy near lemonade stand

comment:1 by fingolfin, 16 years ago

Maybe you mean "subtitles", not "scripting" ? Scripts are what
control the whole game, and there is no way to enable or disable
them.

comment:2 by SF/shirasuwanum, 16 years ago

Sorry, I did indeed mean subtitles, not "scripts".

comment:3 by fingolfin, 16 years ago

Summary: COMI ACT II: Scripting doesn't work or works badlyCOMI: Subtitle problems in Act II

comment:4 by SF/frank_m24, 16 years ago

I can confirm this for German COMI. Seems to happen on
horizontal scrolling screens if Gybrush is on the right side of
the screen. If Gybrush is on the left side the subtitles are
complete. Also the Answer List is affected. Nice to see during
Sword Fights on the ships: If Guybrush is in the lead (=> fight
moves to the left), the sentences are complete, otherwise
they are truncated.

System: WinXP with self-compiled CVS Snapshot from 2004-
01-21 4:00 PM GMT, German COMI played from HD, not from
CD.

best regards

Frank

comment:5 by fingolfin, 16 years ago

Owner: set to fingolfin

comment:6 by fingolfin, 16 years ago

Sounds like a regression due to my recent NUT font renderer
changes. Will look into it once CVS works again.

comment:7 by fingolfin, 16 years ago

Resolution: fixed
Status: newclosed

comment:8 by digitall, 11 months ago

Component: Engine: SCUMM
Game: Monkey Island 3
Note: See TracTickets for help on using tickets.