Opened 18 months ago

Closed 17 months ago

Last modified 16 months ago

#13951 closed defect (fixed)

AGOS: SIMON1 - Music quits (since ScummVM 2.6.0) in certain screens

Reported by: lawadr Owned by: NMIError
Priority: high Component: Engine: AGOS
Version: Keywords: music, midi
Cc: Game: Simon the Sorcerer 1

Description

There are at least a few areas that instantly cause the music to cut out entirely from then on, requiring a restart to get the music back at all.

One area is the path with the bard playing his sousaphone. Another is the goblin areas you get taken to in a box.

This only happens from version 2.6 as 2.5.1 is fine.

Game versions: Windows CD and DOS floppy, both English
Music drivers: Built-in munt, General MIDI, AdLib, makes no difference.

Reproduction: Head to the screen with the bard and his sousaphone. You won't hear the music track. Then head back from where you came. No more music anywhere.

Or just load the attached save.

Attachments (2)

simon1.001 (887 bytes ) - added by lawadr 18 months ago.
simon1.2.001 (798 bytes ) - added by raziel- 17 months ago.
Head to the right, just to where Simon is looking

Download all attachments as: .zip

Change History (8)

by lawadr, 18 months ago

Attachment: simon1.001 added

comment:1 by raziel-, 17 months ago

Confirmed on the Sousaphone screen with

ScummVM 2.7.0git (Jan 13 2023 10:32:54)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 Theora AAC A/52 FreeType2 FriBiDi JPEG PNG GIF cloud (servers, local) TinyGL OpenGL (with shaders)

using original midi hardware with platform specific drivers (CAMD) and

Simon the Sorcerer 1 (CD/Windows/English)

AmigaOS4 - BE - PPC - SDL2

Last edited 17 months ago by raziel- (previous) (diff)

by raziel-, 17 months ago

Attachment: simon1.2.001 added

Head to the right, just to where Simon is looking

comment:2 by raziel-, 17 months ago

Keywords: midi added
Summary: Missing music since ScummVM 2.6.0AGOS: SIMON1 - Music quits (since ScummVM 2.6.0) in certain screens

comment:3 by lotharsm, 17 months ago

Priority: normalhigh

comment:4 by NMIError, 17 months ago

Owner: set to raziel
Resolution: fixed
Status: newclosed

This should be fixed in the next daily build.

comment:5 by raziel-, 17 months ago

Owner: changed from raziel to NMIError

@NMIError

Credit where credit is due :-)

comment:6 by NMIError, 16 months ago

@raziel thanks for confirming the bug and tagging it for AGOS

Note: See TracTickets for help on using tickets.