Opened 18 months ago

Closed 6 months ago

#13946 closed defect (fixed)

SCI: "Failed To Load MT32.DRV" Error Starting Rama

Reported by: bleggett Owned by: sluicebox
Priority: normal Component: Engine: SCI
Version: Keywords:
Cc: Game: RAMA

Description

ScummVM version: 2.6.1
OS: Win 11 64 bit

  1. Copy files from Retail US/English/DOS 3-CD 1.0 version of Rama, as detailed here: https://wiki.scummvm.org/index.php/RAMA
  1. Launch game
  1. Debugger pops up with a "Failed to load MT32.DRV" error - the game never shipped with MT32 support, and no MT32.DRV is present on the game discs, so it seems ScummVM expects a file to be present that is not necessarily always present, depending on the game.

Tried disabling GM and MT-32 in ScummVM settings, no good, still tries to load MT32.DRV - which is not present on the game disks. All that is present on the game discs is MIDNONE.DRV - which I'd expect, I think this game is all-digital sound.

Attachments (4)

crashglobal.png (129.3 KB ) - added by bleggett 18 months ago.
crashglobal2.png (128.8 KB ) - added by bleggett 18 months ago.
failed.png (29.2 KB ) - added by bleggett 18 months ago.
scummvm.ini (29.2 KB ) - added by bleggett 18 months ago.

Download all attachments as: .zip

Change History (8)

comment:1 by sluicebox, 18 months ago

Hello! I've verified that RAMA works with default settings. According to the code, this error message only occurs when ScummVM settings specify MT32. I know you've tried clearing them, but verify that both the Game Options section and the Global Options section are clear. I get confused by these sound settings and I'm unfamiliar with MT32, so apologies for not having more specific GUI advice. You can also try looking at scummvm.ini to see if the stray setting is more obvious there.

If this is still a problem, please provide a copy of your scummvm.ini file for us to look at. Even just the [scummvm] and [rama] sections should be good enough. But I suspect you'll find the setting on your own.

Also, if this is still a problem, please confirm the exact error message. I'm seeing the word "open" and not "load", so we'd want to make sure I'm looking in the right place. =)

Last edited 18 months ago by sluicebox (previous) (diff)

by bleggett, 18 months ago

Attachment: crashglobal.png added

by bleggett, 18 months ago

Attachment: crashglobal2.png added

by bleggett, 18 months ago

Attachment: failed.png added

by bleggett, 18 months ago

Attachment: scummvm.ini added

comment:2 by bleggett, 18 months ago

Okay, I did some more fiddling - I agree they're confusing. Part of the problem is that Game Options do not expose MT-32 overrides, so if you have both GM and MT-32 devices enabled globally in Global Options, you cannot configure everything you need on a per-game basis by just setting overrides in Game Options, and end up having to twiddle things in Global Options for each game.

Anyway - here is the behavior I see:

  1. Set MIDI to "Don't Use MIDI" in Global Settings.
  2. Set MT-32 to "Don't Use MT-32" in Global Settings.
  3. Leave Game Options audio override *unchecked* for RAMA

Get the error screen in the screenshot.

If I check Override Global Audio Settings in the Game Options and set Music Device to <default> the game starts without the crash, which doesn't make any sense - I have disabled both MIDI and MT-32 globally, what is there to override?

Also attached scummvm.ini.

Summary: I can get the game working but it's not clear to me why I need the Game Options override in addition to disabling all the MIDI devices globally.

comment:3 by sev-, 6 months ago

Summary: "Failed To Load MT32.DRV" Error Starting RamaSCI: "Failed To Load MT32.DRV" Error Starting Rama

comment:4 by sluicebox, 6 months ago

Owner: set to sluicebox
Resolution: fixed
Status: newclosed

Fixed in: https://github.com/scummvm/scummvm/commit/ff779d72ddb0d1d91482217dec87872663a476ad

Thanks again for reporting this. I recently did some unrelated fixes involving the code that was throwing this error, so now I'm just familiar enough to see the real problem.

Note: See TracTickets for help on using tickets.