Opened 2 weeks ago

Closed 2 weeks ago

#13943 closed defect (invalid)

King Quest 5 keeps crashing in the exact same spot

Reported by: SAL150 Owned by: sluicebox
Priority: normal Component: Engine: SCI
Version: Keywords:
Cc: Game: King's Quest 5

Description

Hi, every time i get to the desert and try to enter the thiefs area the game crashes always. cant finish the game at all.
i tried to restart the game still the same. please help

game version is the CD from GOG
Scummvm is the latest version 2.6.1
Windows 10 64Bit latest updates installed and drivers too

Attachments (2)

king q 5.jpg (69.4 KB ) - added by SAL150 2 weeks ago.
scummvm crash bt.png (743.7 KB ) - added by SAL150 2 weeks ago.

Download all attachments as: .zip

Change History (8)

by SAL150, 2 weeks ago

Attachment: king q 5.jpg added

comment:1 by sluicebox, 2 weeks ago

Hello! Thank you for reporting this and providing all those useful version details.

We just need a save game file from soon before the crash so that we can reproduce this and figure out what's going wrong. You can attach one or several to this ticket. On Windows those files are located at:

%APPDATA%\ScummVM\Saved games

It would also be helpful if on that yellow error screen, you type the command "bt", press enter, and screenshot that. That will give us useful information.

comment:2 by SAL150, 2 weeks ago

Thanks for the reply, theres no need for save game as this will happen no matter if its new game or from a saved game. like i said i have restarted the game form the beginning and walk to that area without doing anything else and still crashed, i have also followed a walkthrough and did exactly like him and for me it always crashed.

i will do what you said and add new screenshot, hope this helps

by SAL150, 2 weeks ago

Attachment: scummvm crash bt.png added

comment:3 by sluicebox, 2 weeks ago

Thank you for the screenshot. As I suspected from the error message, none of this makes any sense. =)

I can't reproduce this; the thieves' camp works for me. KQ5 is popular; if it were broken for everyone we would have heard about this by now from a lot of people.

That error message, combined with that bt stacktrace, isn't possible according my copy of the game. And there's only one CD version. There's probably something wrong with your game files. Sierra games rely on a bunch of little files and if they're not all the right ones, or some are missing, or there are extras, then things start out okay but get weird later.

I believe that if you were to copy over the genuine game files again from original media or GOG or wherever it would work. "Oops, nevermind, I copied the files again and it worked" is how I close a lot of these tickets =) If you provide a directory listing with file sizes of your KQ5 directory (the one with RESOURCE.MAP), I can compare those.

This is where a save file would help, although I predict that I wouldn't even be able to load it, because I believe your copy of the game is invalid. Even that would be helpful though, because it would confirm the cause.

But it could be something else! Try ruling out bad files first. Btw if you'd on discord and need help, you can ping me on the scummvm server.

comment:4 by SAL150, 2 weeks ago

I have tried to reinstall the game many times that didn't do anything. but from what your saying that it could be some files is broken.
but i haven't tried to uninstall the game and delete everything then download the game again from GOG and try to install again fresh install maybe the file that i downloaded was bad or something, so im goanna try that and let you know

comment:5 by SAL150, 2 weeks ago

Ok that fixed it :)
something must got bad when i downloaded it my internet is not stable that must be the cause of it, so thank you so much anyway

comment:6 by sluicebox, 2 weeks ago

Keywords: crash removed
Owner: set to sluicebox
Resolution: invalid
Status: newclosed

Excellent! Happy to hear it's working; have fun KQ5'ing!

Note: See TracTickets for help on using tickets.