#13930 closed defect (fixed)

KQ3 Redux crashes with "Error: SetTextOverlay internal error: inconsistent type ids"

Reported by: brainiac744 Owned by: tag2015
Priority: normal Component: Engine: AGS
Version: Keywords:
Cc: Game:

Description (last modified by brainiac744)

I get a consistent crash when entering the cave containing the mandrake root.

To reproduce: enter the cave, pick up the mandrake root, talk to the person that appears.

A cutscene starts, and I crash to desktop with:

An internal error has occurred. Please note down the following information. (ACI version 3.6.0.25)

Error: SetTextOverlay internal error: inconsistent type ids

I've attached a savegame just outside the cave.

Here is the output of scummvm -v

ScummVM 2.6.1 (Oct 17 2022 10:09:38)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 FluidSynth Theora AAC A/52 FreeType2 FriBiDi JPEG PNG GIF taskbar TTS cloud (servers, local) TinyGL OpenGL (with shaders)

I also tried a daily build yesterday and had the same problem - sorry, didn't note down the version of it.

I'm running on Windows 10 Pro 64 bit 21H2

Attachments (1)

kq3agdi.002 (455.6 KB ) - added by brainiac744 19 months ago.

Download all attachments as: .zip

Change History (6)

by brainiac744, 19 months ago

Attachment: kq3agdi.002 added

comment:1 by brainiac744, 19 months ago

Description: modified (diff)

comment:2 by nickkeane, 17 months ago

Getting the same issue but in the intro outside the house when the wizard starts talking, or when pressing escape to get to the main menu. The ACI Version is listed as 3.6.0.31.

Using ScummVM 2.7.0git3423-gacee74a4b76

Last edited 17 months ago by nickkeane (previous) (diff)

comment:3 by tag2015, 16 months ago

Hi, thanks for the report.
Could you try a daily build?
https://buildbot.scummvm.org/#/dailybuilds

The crashes caused by SetTextOverlay should be solved (I played the entire intro and the mandrake part using your save)
Thanks!

comment:4 by brainiac744, 16 months ago

I can confirm that the windows daily build (348e0d7a) gets past the crash I was hitting previously. Thanks!

comment:5 by tag2015, 16 months ago

Owner: set to tag2015
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.