#13924 closed defect (fixed)

SCUMM: FT: Ben sometimes gets stuck in an endless loop in old mine road

Reported by: dwatteau Owned by: dwatteau
Priority: normal Component: Engine: SCUMM
Version: Keywords: loop, old mine road, goggles
Cc: Game: Full Throttle

Description

ScummVM HEAD, either on macOS, Linux, Windows or PS3. Playing with the DOS/French version (I don't think the problem could be related to the language, though).

  1. Start the game with boot param 551
  2. Left-click when you see the sign for the old mine road, in order to go there
  3. If you can see another biker on the screen, press Esc. (Otherwise, the following action won't be available.)
  4. When you're approaching any road sign for Highway 9, right-click so that Ben puts on the goggles. There's something timing-related to trigger there: the idea is to right-click a few seconds before the road sign, so that Ben puts on the goggles exactly when the road sign icon appears/disappears from the bottom left corner of the screen.
  5. You may need to repeat the previous action dozens of time before triggering the bug. At some point, Ben will be stuck in an endless loop where he immediately puts on and puts off the goggles.

See this video as an example:
https://www.youtube.com/watch?v=cEhTfrHsEdg

I can't provide a savegame where this is happening, since the game disables any save action during the INSANE sequences.

There are other ways to trigger this issue, but that one appears to be the "easiest" one to trigger. Other ways include:

  • putting the goggles on when Ben is very close to the edge of the road, and is about to fall off his bike.
  • endlessly drive around the road signs in the old mine road, without touching the keyboard or mouse. At some point, Ben will endlessly enter/leave the old mine road, although you haven't triggered any action.

I can reproduce this with ScummVM 2.0.0, and a late November 2017 build, so it doesn't look like a recent regression. I'm not able to reproduce this with an earlier build yet, but since it can take minutes and dozens of random tries to trigger this bug, that doesn't really mean a lot. Tried using Git bisect twice around the 1.9.0/2.0.0 area, but it lead me nowhere.

I couldn't reproduce this issue with the original game (DREAMM, Aaron Giles 2002 interpreter, 2017 remaster) either, at the moment.

Change History (3)

comment:1 by dwatteau, 19 months ago

Just to confirm that I can also trigger this with the Version B/English release (extracted from the 2017 remaster).

comment:2 by dwatteau, 18 months ago

Owner: set to dwatteau
Resolution: fixed
Status: newpending

This has just been (very likely) fixed by AndywinXp in commit 078bfa70cd777e1d25694b3b758f4e5ac5e10fcf. Thanks!

I can't reproduce the problem anymore, but I'm keeping this issue pending for a few days, since triggering it was a bit random.

comment:3 by dwatteau, 18 months ago

Status: pendingclosed

I've tested this again on the 3 devices where I was having this issue, and I really can't trigger this bug anymore. Closing, then.

Thanks Andrea!

Note: See TracTickets for help on using tickets.