Opened 16 months ago

Closed 3 months ago

#13920 closed defect (fixed)

MOHAWK: LB - French sheila version not starting

Reported by: laenion Owned by: sev-
Priority: high Component: Engine: Mohawk
Version: Keywords:
Cc: Game:

Description

The French version of "Sheila Rae the Brave" is not starting due to an error in the INI file format of SRAEF.LB: One line just contains several 0x7f characters.

Due to that ScummVM crashes with the following messages:

Running Sheila Rae, the Brave (Windows/French)
SRAEF.LB: 96b00fc4b44c0e881c674d4bae5aa79a, 6121 bytes.
Opening hashed: SRAEF.LB
WARNING: Config file buggy: Junk found in line line 19: ''!
PrimaryLanguage = "French"
Language = "French"
Language1 = "French"
Language2 = "German"
Language3 = "English"
while parsing script ' = ', couldn't parse ''!
Segmentation fault

Change History (5)

comment:1 by laenion, 16 months ago

Component: --Unset--Engine: Mohawk

comment:2 by sev-, 4 months ago

Priority: normalhigh

It would be nice to get it fixed before the 2.8.0 release.

We need to make our INI parser more robust, by adding a flag to ignore garbage like this.

comment:3 by lotharsm, 3 months ago

For reference, there's a pull request targeting this problem:

https://github.com/scummvm/scummvm/pull/5482

comment:4 by sluicebox, 3 months ago

There are two bugs in this ticket:

  1. Script parsing called error
  2. error segfaulted instead of displaying the debugger with the error message

I fixed the second one: https://github.com/scummvm/scummvm/commit/02682424609b74ab286fd8ce4aac0bb81f512e4d

comment:5 by sev-, 3 months ago

Owner: set to sev-
Resolution: fixed
Status: newclosed

The PR has been merged. The problem is fixed now. Also, backported to 2.8.0?

Note: See TracTickets for help on using tickets.