Opened 3 months ago

Closed 11 days ago

#13917 closed defect (fixed)

BACKENDS: iOS: Default touchpad mode unusable on iOS 16

Reported by: dwatteau Owned by: larsamannen
Priority: normal Component: Port: iOS
Version: Keywords: touchpad mode, controls
Cc: Game:

Description

larsman on Discord asked to file a bug report about this.

I'm not a regular user of the iOS port, but it's been reported that the default iOS controls (i.e. "touchpad mode") became unusable since iOS 16 was released.

(At first we thought it could be related to https://9to5mac.com/2022/09/15/ios-16-bug-three-finger-games/ but upgrading to iOS 16.1 didn't solve the issue.)

I can confirm this with iOS 16.1 running on an iPhone 8 Plus (built with Xcode 14 and just following our iOS build documentation, on current Git HEAD):

  • the (default) "touchpad mode" controls are almost unusable: whenever you do a single-tap somewhere, the cursor will move away by a significant amount, and so it's almost impossible to hit any button or do any point-n-click action (as if using a really poor touchscreen)
  • "Non-touchpad mode, mouse, Magic Keyboard and game controllers seems to work properly" (larsman)

Unfortunately, my only iOS device has been updated to iOS 16 and so I can't test iOS 15 back to confirm whether this is an iOS 15 => 16 regression. I can't reproduce this issue in the Xcode iPhone simulator, though.

Change History (3)

comment:1 by larsamannen, 2 months ago

I’ll have a look at it.

comment:3 by dwatteau, 11 days ago

Owner: set to larsamannen
Resolution: fixed
Status: newclosed

Thanks!

Note: See TracTickets for help on using tickets.