Opened 17 months ago

Closed 17 months ago

Last modified 15 months ago

#13906 closed defect (duplicate)

AGS: Quest For Glory 2 AGS remake mouse input seems broken

Reported by: bleggett Owned by: bleggett
Priority: normal Component: Engine: AGS
Version: Keywords:
Cc: Game:

Description (last modified by bleggett)

Playing QFG 2 AGS remake in the latest daily build (Win11/Oct 22, 2022), every time I click the mouse normally in the game it seems as if the game reads it as many extremely fast clicks, to the point where the game UI freaks out - seems like either a speed or input polling/debounce issue.

Can be seen from the beginning of the game.

Tested with 2.6.0 and did not see the issue - so this seems to be a regression.

Video example: https://youtu.be/HwC-wO6pvUs

Change History (6)

comment:1 by bleggett, 17 months ago

Description: modified (diff)

comment:2 by bleggett, 17 months ago

Description: modified (diff)

comment:3 by tag2015, 17 months ago

Summary: Quest For Glory 2 AGS remake mouse input seems brokenAGS: Quest For Glory 2 AGS remake mouse input seems broken

Thanks for the report, I think this is still bug #13894

comment:4 by tag2015, 17 months ago

Game: AGI Fanmade

comment:5 by bleggett, 17 months ago

Owner: set to bleggett
Resolution: duplicate
Status: newclosed

You're correct, it is, thx - I searched but somehow missed that one.

Closing as a dupe of #13894

comment:6 by Terelyn, 15 months ago

The game is unplayable with this bug present.

Note: See TracTickets for help on using tickets.