#13869 closed defect (fixed)

PINK: Can't pickup the poker in sir Manley's house

Reported by: kermitoo Owned by: antoniou79
Priority: normal Component: Engine: Pink
Version: Keywords:
Cc: Game: Pink Panther: Passport to Peril

Description (last modified by sev-)

ScummVM 2.7.0git2993-g5a13c15a550 (Sep 28 2022 04:46:06)

French version of the game.

On my first playtrough all went fine, but on second playtrough I wasn't able to pickup the poker next to the fireplace. You need it to use on the coat of arms and progress in the game.

Attachments (2)

peril-fr.s08 (21.5 KB ) - added by kermitoo 20 months ago.
Glitched save in which you can't pickup the poker
peril-fr.s11 (24.6 KB ) - added by kermitoo 20 months ago.
Save just before entering sir Manley's house for testing

Download all attachments as: .zip

Change History (5)

by kermitoo, 20 months ago

Attachment: peril-fr.s08 added

Glitched save in which you can't pickup the poker

by kermitoo, 20 months ago

Attachment: peril-fr.s11 added

Save just before entering sir Manley's house for testing

comment:1 by tag2015, 20 months ago

Summary: Can't pickup the poker in sir Manley's housePINK: Can't pickup the poker in sir Manley's house

comment:2 by antoniou79, 13 months ago

This issue seems to be caused from global game variables (_variables array member of the PinkEngine class), that were not cleared up when starting a new game.

This means that the attached saved games are carrying stale global variable values; for example, here the "GotPoker" game variable already has the "TRUE" value in both attached saved games.

I've issued a PR with a potential fix for this here: https://github.com/scummvm/scummvm/pull/4944

As stated in that PR, this would fix the issue if a user were to start a *new game* again properly, but it will not retro-actively fix the awry saved games (eg the attached ones).

It does also not address the case of using the console debugger to jump around game modules and pages, which is guaranteed to make a mess of these global game variable values and potentially cause unexpected behavior (similar to the poker issue). But at least a "New Game" would still clear everything up.

comment:3 by sev-, 13 months ago

Description: modified (diff)
Owner: set to antoniou79
Resolution: fixed
Status: newclosed

Fixed in the above mentioned PR

Note: See TracTickets for help on using tickets.