Opened 4 months ago

#13864 new defect

SCUMM/HE: Blue's Treasure Hunt - Missing Backgrounds during some animations

Reported by: Thunderforge Owned by:
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game: Blue's Treasure Hunt

Description

This ticket was split off from #12505, posted by @cheatfreak47

I went ahead and went over my own copy of Blue's Clues: Blue's Treasure Hunt with a fine-toothed comb in the latest daily build ScummVM (at the time: windows-x86-64-master-cb14f43e), copying the files as instructed by the Wiki page and hunted for problems and came up with only a few.

Attached I will post some more or less completed savegames to try and assist with dev, but I don't know how useful they will be.

Worth noting that the actual game does work on modern Windows 10 with no issues, and can be windowed for comparison to scummVM.


During sequences where Steve "Skidoos" into subareas, a background fails to render for some reason during a part of the animation. This also happens during/after the "found all 3 clues!" sequence, where steve is supposed to be shown sitting on his chair.
https://i.imgur.com/KfJR2yI.png
https://i.imgur.com/ImxKjQ0.png

Attachments (3)

Saved games.7z (3.3 KB ) - added by Thunderforge 4 months ago.
ImxKjQ0.png (70.1 KB ) - added by Thunderforge 4 months ago.
KfJR2yI.png (92.5 KB ) - added by Thunderforge 4 months ago.

Download all attachments as: .zip

Change History (3)

by Thunderforge, 4 months ago

Attachment: Saved games.7z added

by Thunderforge, 4 months ago

Attachment: ImxKjQ0.png added

by Thunderforge, 4 months ago

Attachment: KfJR2yI.png added
Note: See TracTickets for help on using tickets.