Opened 22 months ago

Closed 9 days ago

#13862 closed defect (invalid)

SCUMM/HE: Blue's Treasure Hunt - Breakout Minigame does not load levels correctly

Reported by: Thunderforge Owned by: AndywinXp
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game: Blue's Treasure Hunt

Description (last modified by Thunderforge)

This ticket was split off from #12505, posted by @cheatfreak47

I went ahead and went over my own copy of Blue's Clues: Blue's Treasure Hunt with a fine-toothed comb in the latest daily build ScummVM (at the time: windows-x86-64-master-cb14f43e), copying the files as instructed by the Wiki page and hunted for problems and came up with only a few.

Attached I will post some more or less completed savegames to try and assist with dev, but I don't know how useful they will be.

Worth noting that the actual game does work on modern Windows 10 with no issues, and can be windowed for comparison to scummVM.


On Disc 2, there is a minigame you can play either by completing the game, or by pressing the A key while on the chapter select screen and choosing it on the bottom right from the Activity Select. (I believe it is room 54 if you use the debugger to warp)

Simply put, this doesn't work as intended. It only shows 4 levels and they're all a garbled mess. The intention is for there to be about 100 levels. I believe these are contained by files in /data/levels/, probably in the .BRE files or .WIZ files, but I am not sure how this all works exactly.
https://i.imgur.com/dNQs7r2.png

https://youtu.be/xXSNHZX0DDY?t=3132
This video here could be used as reference for what the Breakout Minigame's intended behavior is like.

Attachments (2)

Saved games.7z (3.3 KB ) - added by Thunderforge 22 months ago.
dNQs7r2.png (53.4 KB ) - added by Thunderforge 22 months ago.

Download all attachments as: .zip

Change History (6)

by Thunderforge, 22 months ago

Attachment: Saved games.7z added

by Thunderforge, 22 months ago

Attachment: dNQs7r2.png added

comment:1 by Thunderforge, 22 months ago

Description: modified (diff)

comment:2 by AndywinXp, 10 days ago

Okay, I kind of figured it out: the scripts are trying to open blues2.he9 to load the breakout levels. The issue is... the .he9 file in the CD is called Blue'sTreasureHunt-Disc2.he9 instead. So the scripts, in our case, acknowledge that this file does not exist, and open a bunch of debug levels instead, which are the ones you are seeing.

The missing element of the puzzle is how to actually make this work in the same way they did... I'm guessing it has something to do with the way the game is installed from the original CD, since it copies some file over to the hard drive. But I'll figure out the rest tomorrow...

Last edited 10 days ago by AndywinXp (previous) (diff)

in reply to:  2 comment:3 by AndywinXp, 10 days ago

[snip]

Last edited 10 days ago by AndywinXp (previous) (diff)

comment:4 by AndywinXp, 9 days ago

Owner: set to AndywinXp
Resolution: invalid
Status: newclosed

Oh... THAT's why it wasn't working:

[0013] (5D)     if (VAR_DEBUG_ENABLED) { <---- HERE!
[0019] (43)       localvar1 = readINI.string("SCUPath")
[002A] (A4)       localarray2["blues2.he9"] = "blues2.he9"
[003D] (A4)       roomarray24["%s%s"] = "%s%s"
[0052] (BC)       dimArray.nukeArray(localvar1)
[0056] (BC)       dimArray.nukeArray(localvar2)
[005A] (5D)     } else if (VAR_PLATFORM == 2) {
[0066] (A4)       roomarray24["%s%s (9)"] = "%s%s (9)"
[007F] (73)     } else {
[0082] (A4)       roomarray24["%s%s.he9"] = "%s%s.he9"
[009B] (**)     }

Remember kids, never debug your SCUMM games on debug mode, because they do silly stuff :P

Closing, on release mode this works exactly as it should...

Note: See TracTickets for help on using tickets.