Opened 20 months ago

Closed 4 months ago

#13849 closed defect (fixed)

ULTIMA8: Hero is out of the screen, unable to bring him back

Reported by: aybe Owned by: OMGPizzaGuy
Priority: normal Component: Engine: Ultima
Version: Keywords:
Cc: Game: Ultima VIII: Pagan

Description (last modified by aybe)

So just before entering the city, been walking to top left of screen but then I'm unable to come back no matter what.

C:\Program Files\ScummVM>scummvm.exe -v
ScummVM 2.6.0 (Jul 17 2022 00:04:49)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 FluidSynth Theora AAC A/52 FreeType2 FriBiDi JPEG PNG GIF taskbar TTS cloud (servers, local) TinyGL OpenGL (with shaders)

Attachments (2)

Saved Games.zip (391.9 KB ) - added by aybe 20 months ago.
scummvm_pB0axvtGgc.png (1.6 MB ) - added by aybe 20 months ago.

Download all attachments as: .zip

Change History (8)

by aybe, 20 months ago

Attachment: Saved Games.zip added

by aybe, 20 months ago

Attachment: scummvm_pB0axvtGgc.png added

comment:1 by mduggan, 20 months ago

Component: --Unset--Engine: Ultima

Thanks for including the save games, it helps a lot.

To confirm, which version are you on - the latest release (2.6.0), nightly build, or local build?

comment:2 by mduggan, 20 months ago

Summary: Hero is out of the screen, unable to bring him backULTIMA8: Hero is out of the screen, unable to bring him back

comment:3 by aybe, 20 months ago

Description: modified (diff)
Summary: ULTIMA8: Hero is out of the screen, unable to bring him backHero is out of the screen, unable to bring him back

in reply to:  1 comment:4 by aybe, 20 months ago

Replying to mduggan:

Thanks for including the save games, it helps a lot.

To confirm, which version are you on - the latest release (2.6.0), nightly build, or local build?

Just added the version, downloaded from web site.

comment:5 by aybe, 20 months ago

Summary: Hero is out of the screen, unable to bring him backULTIMA8: Hero is out of the screen, unable to bring him back

comment:6 by OMGPizzaGuy, 4 months ago

Owner: set to OMGPizzaGuy
Resolution: fixed
Status: newclosed

It looks like the camera is not connected to the Avatar while a pathfinding process took him off screen. Using the console command CameraProcess::moveToAvatar shows him once again but does not lock the camera to the player.

I am fairly certain this should not be possible since fixing #13875 - so I'll close this for now. Please reopen if you are able to reproduce this in newer releases.

Note: See TracTickets for help on using tickets.