Opened 2 weeks ago

Closed 11 days ago

#13845 closed defect (fixed)

SCUMM: COMI: core dumped after a while

Reported by: mcanonic Owned by: AndywinXp
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game: Monkey Island 3

Description

Hi,
in my linux fedora 35 and ScummVM 2.0.6 I have no problems since the end of Chapter 2 when I got this error from the console:

[code]scummvm: engines/scumm/imuse_digi/dimuse_sndmgr.cpp:245: void Scumm::ImuseDigiSndMgr::scheduleSoundForDeallocation(int): Assertion `checkForProperHandle(soundDesc)' failed.
Aborted (core dumped)
code

Before that error, when I load the game I get these warning but they do not really have some problem with the game
[code]User picked target 'comi-it' (engine ID 'scumm', game ID 'comi')...

Looking for a plugin supporting this target... SCUMM [all games]

WARNING: BundleMgr::open() Can't open bundle file: voxdisk2.bun!
WARNING: BundleMgr::open() Can't open bundle file: musdisk2.bun!
WARNING: BundleMgr::open() Can't open bundle file: musdisk2.bun!
WARNING: BundleMgr::open() Can't open bundle file: musdisk2.bun!
code

To reproduce the bug, nothing particular has to be done: I've just finished the second part.

Before that, the game works perfectly so I suppose that the source code and CDs imported are ok.

Change History (4)

comment:1 by mcanonic, 2 weeks ago

The problem was related to that warning.
The files were missing, so scummvm should rise an error not a warning.

I was missing that file due to a problem on the CD's files extraction.

You can close the ticket, but I suggest to think about these "warnings" that must be "errors".

Last edited 2 weeks ago by mcanonic (previous) (diff)

comment:2 by AndywinXp, 11 days ago

Grazie!
We try to provide a smooth gaming experience even when not-strictly-necessary files (music and voices) are not used (e.g. you might want to copy the files from Steam to your tablet/smartphone but you don't want to occupy all that space).

This is the reason why that's a warning instead of an error. But indeed, it shouldn't behave like this and it certainly shouldn't throw the assertion error in this case: I'll see what I can do!

Ciao!

comment:4 by AndywinXp, 11 days ago

Component: --Unset--Engine: SCUMM
Game: Monkey Island 3
Owner: set to AndywinXp
Resolution: fixed
Status: newclosed
Summary: Monkey3: core dumped after a whileSCUMM: COMI: core dumped after a while
Note: See TracTickets for help on using tickets.