#13844 closed defect (duplicate)

GRIFFON: Game hangs on a black screen on PSP

Reported by: dwatteau Owned by: dwatteau
Priority: normal Component: Engine: Griffon
Version: Keywords: psp, black screen, loading, stuck
Cc: Game: Griffon Legend

Description

This has been reported by user NiccaTales on the forums:
https://forums.scummvm.org/viewtopic.php?t=16653

I don't own a PSP, but I can reproduce the issue with the PPSSPP emulator and the regular 2.6.0 build for that platform.

  1. Download the game (the wiki says that it's freeware)
  2. Start it on a PSP or on a PSP emulator
  3. The game just hangs on a black screen and never starts (even if you wait 10 minutes).

I have no idea how/if ScummVM can be run in debug mode on the PSP, but FWIW I have an old MIPS netbook where I see that the game also hangs on a black screen between 45 seconds and 1 minute. It looks like it could be related to BitmapRawDecoder::decodeFrame() being slow; for example looking art/clouds.bmp takes several seconds there. But I'm not sure the PSP problem is related to this, since the game never seems to load at all on the PSP.

Change History (3)

comment:1 by ccawley2011, 17 months ago

This might be the same problem as with issue #12585, since the Griffon engine currently requires the same pixel format.

comment:2 by dwatteau, 17 months ago

Indeed, that's a duplicate, I see the same content in SCUMMTRACE.TXT. Closing this issue since the other one is older and more general.

comment:3 by dwatteau, 17 months ago

Owner: set to dwatteau
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.