Opened 5 months ago

Closed 4 months ago

Last modified 3 months ago

#13827 closed defect (wontfix)

SCI: QfG4 - Game gets frozen for some seconds when walking to the castle

Reported by: lwcorp Owned by: bluegr
Priority: normal Component: Engine: SCI
Version: Keywords:
Cc: Game: Quest for Glory 4

Description (last modified by lwcorp)

When walking during day time to the castle, the game gets frozen for a few a seconds before the castle gate greets you.

During night time there's a lightning so I have a feeling even during day time it waits for that thunder, but it shouldn't.

Tried via v2.7.0git2430-g139536ced1a (Sep 3 2022 04:02:45).

Attachments (2)

qfg4-cd.001 (46.5 KB ) - added by lwcorp 5 months ago.
Save game before walking to the castle
Frozen_for_a_moment_-_Quest_for_Glory_IV__Shadows_of_Darkness_CD_DOS_English_2022-08-27_10-18-15.mp4 (2.0 MB ) - added by lwcorp 5 months ago.
Video showing how the game gets frozen for a few seconds when walking to the castle

Change History (5)

by lwcorp, 5 months ago

Attachment: qfg4-cd.001 added

Save game before walking to the castle

by lwcorp, 5 months ago

Video showing how the game gets frozen for a few seconds when walking to the castle

comment:1 by lwcorp, 5 months ago

Description: modified (diff)

comment:2 by bluegr, 4 months ago

Owner: set to bluegr
Resolution: wontfix
Status: newclosed

That is the expected behavior. Game scripts await for 5 seconds when entering the room for dramatic effect.
There are 9 different events that can occur when the hero enters from the west, and they all contain this code. Patching them to wait less is possible, but I really don't see the point, since this delay is intentional.

For reference, in this particular save, sEvent3 is called, which does a delay of 5 seconds. The possible events are sEvent2 - sEvent10, right after setting the script to sFromSouth.

Since this delay is intentional and is added for dramatic effect, there is no reason to change it. Closing as wontfix

comment:3 by lwcorp, 3 months ago

I see your point but as mentioned during the night there's a thunder after those 5 seconds.
But during the day there's nothing dramatic there, just a lovely sky and a bored gatekeeper. It seems like it waits in vain for the thunder.

Note: See TracTickets for help on using tickets.