Opened 16 years ago

Closed 16 years ago

#1382 closed defect (fixed)

SAM: Drawing regression in Sam & Max

Reported by: eriktorbjorn Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Sam and Max

Description

I don't know when this was introduced, but drawing
appears to be almost completely broken in Sam & Max
with the latest CVS snapshot.

In the intro - what little I could stand to watch of it
- only the animated bits are visible, and even they are
sometimes masked by left-over text masks.

In the first room, either the background wasn't visible
at all, or it was being erased as Sam and Max were
walking across it. I saw both these cases happen, but
maybe that depends on where I escaped the intro.

I didn't see this happen with any of the other games I
tried.

Ticket imported from: #873688. Ticket imported from: bugs/1382.

Change History (5)

comment:1 by eriktorbjorn, 16 years ago

I tried it with a snapshot from yesterday. It didn't have
this problem, so it's a recent regression. Funny, I thought
most of the changes since yesterday were renaming and moving
stuff around, without much changes in functionality.

comment:2 by eriktorbjorn, 16 years ago

Summary: SAM: Drawing regression in Sam & MaxSAM: Drawing regression in Sam & Max

comment:3 by eriktorbjorn, 16 years ago

It probably has something to do with the new isLightOn()
function. If I change it to always return true, it looks
fine again.

Obviously this isn't the correct fix; it's merely an
observation.

comment:4 by eriktorbjorn, 16 years ago

Owner: set to fingolfin

comment:5 by fingolfin, 16 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.