#13783 closed defect (wontfix)

BASE/GFX: VSYNC setting doesn't works for GRIM engine and FPS always hardcoded to 60.

Reported by: kas1e Owned by: aquadran
Priority: normal Component: Engine: Grim
Version: Keywords: 3D
Cc: kas1e Game: Grim Fandango

Description

Since somewhere 25 June (i assume when this commit were done: https://github.com/scummvm/scummvm/commit/97f45352fc7cb8aac0bc27e737498ad6074074a0 ) , GRIM engine (so mean GRIM game and Monkey4 as well), do not reflet anymore to the FPS vsync being on/off, but always show 60-62 FPS, which kind of make showing FPS for comparing/meassuring a waste.

For example, in the build done on june 22, i got in Grim Fardango about 10000-11000 FPS in the intro of Grim and about 150 FPS in the game on my AmigaOS machine, but since june 25 , i do have everywhere 60 FPS. And that kind of killing ability to compare speed improvements and meassure real FPS to compare between machines/drivers/etc.

I think that because of that commit where 60 hardcore FPS were added. Also i did see in the GRIM code (even in yesterday's scummvm code), that it still trying to use "60" as the base.

But, this should be as "base" when VSYNC set to ON probably. And when to VSYNC is OFF, this code should't have take the place.

Change History (4)

comment:1 by raziel-, 19 months ago

Keywords: 3D added
Summary: Hardcore 60 FPS in GRIM games which not reflet VSYNC on/offBASE/GFX: VSYNC setting doesn't reflect hardcoded 60 FPS in 3D games

To make it short (and to cc myself)

If I understand it correctly VSYNC set to ON should cap FPS at 60 and
VSYNC set to OFF shouldn't, correct?

Right now both settings cap 3D games at 60 FPS.
Or is there another reason why that is?

Thank you

comment:2 by kas1e, 19 months ago

Yeah, VSYNC ON should be 60 FPS , and VSYNC OFF should not set any hardcore FPS limit, but when VSYNC is OFF games should give the maximum possible as it was prior to 25 june commits.

On june 25 there were added this in base/commandline.cpp:

ConfMan.registerDefault("engine_speed", 60); // FPS limit for 3D games

So, now does not matter do use enable VSYNC or disable, in GRIM (and so in Monkey4) you do have 60-62 FPS all the time, and can't measure anything anymore.

Once i comment out thins string and recompile code (even code from august 15), then everything back to normal, and i have ~10000 FPS in intro of GRIM and 140 FPS in first game scenes.

Last edited 19 months ago by kas1e (previous) (diff)

comment:3 by kas1e, 19 months ago

Summary: BASE/GFX: VSYNC setting doesn't reflect hardcoded 60 FPS in 3D gamesBASE/GFX: VSYNC setting doesn't works for GRIM engine and FPS always hardcoded to 60.

comment:4 by aquadran, 19 months ago

Owner: set to aquadran
Resolution: wontfix
Status: newclosed

this is not a bug

Note: See TracTickets for help on using tickets.