Opened 4 months ago

Closed 7 weeks ago

#13781 closed defect (fixed)

STARK: The Longest Journey crashes with Assertion failed

Reported by: nix234 Owned by: nix234
Priority: high Component: Engine: Stark
Version: Keywords:
Cc: nix234 Game: The Longest Journey

Description

TLJ works with residualvm but not with scummvm.

❯ scummvm -v
ScummVM 2.6.0 (Aug 15 2022 11:07:20)
Features compiled in: TAINTED Vorbis FLAC MP3 SEQ TiMidity RGB zLib MPEG2 FluidSynth Theora AAC A/52 FreeType2 FriBiDi JPEG PNG GIF cloud (local) TinyGL OpenGL (with shaders)

❯ ./residualvm -v
ResidualVM 0.4.0git987-g1b968fd1b (Aug 30 2020 14:51:33)
Features compiled in: Vorbis MP3 ALSA RGB zLib MPEG2 Theora FreeType2 FriBiDi JPEG PNG

❯ uname -a
FreeBSD freeb 13.1-RELEASE-p1 FreeBSD 13.1-RELEASE-p1 GENERIC amd64

Crashlog:

User picked target 'tlj-win-de-1' (engine ID 'stark', game ID 'tlj')...

Looking for a plugin supporting this target... Stark

Running The Longest Journey (DVD/Windows/German)
x.xarc: de8327850d7bba90b690b141eaa23f61, 3032 bytes.
chapters.ini: e4611d143a87b263d8d7a54edc7e7cd7, 515 bytes.
INFO: OpenGL Vendor: AMD
INFO: OpenGL Renderer: AMD Radeon RX 580 Series (POLARIS10, DRM 3.35.0, 13.1-RELEASE-p1, LLVM 13.0.1)
INFO: OpenGL Version: 4.6 (Compatibility Profile) Mesa 21.3.8
INFO: OpenGL Red bits: 8
INFO: OpenGL Green bits: 8
INFO: OpenGL Blue bits: 8
INFO: OpenGL Alpha bits: 8
INFO: OpenGL Z buffer depth bits: 24
INFO: OpenGL Double Buffer: 1
INFO: OpenGL Stencil buffer bits: 8
INFO: GLSL version: 4.60
INFO: OpenGL Vendor: AMD
INFO: OpenGL Renderer: AMD Radeon RX 580 Series (POLARIS10, DRM 3.35.0, 13.1-RELEASE-p1, LLVM 13.0.1)
INFO: OpenGL Version: 4.6 (Compatibility Profile) Mesa 21.3.8
INFO: OpenGL Red bits: 8
INFO: OpenGL Green bits: 8
INFO: OpenGL Blue bits: 8
INFO: OpenGL Alpha bits: 8
INFO: OpenGL Z buffer depth bits: 24
INFO: OpenGL Double Buffer: 1
INFO: OpenGL Stencil buffer bits: 8
INFO: GLSL version: 4.60
INFO: OpenGL Vendor: AMD
INFO: OpenGL Renderer: AMD Radeon RX 580 Series (POLARIS10, DRM 3.35.0, 13.1-RELEASE-p1, LLVM 13.0.1)
INFO: OpenGL Version: 4.6 (Compatibility Profile) Mesa 21.3.8
INFO: OpenGL Red bits: 8
INFO: OpenGL Green bits: 8
INFO: OpenGL Blue bits: 8
INFO: OpenGL Alpha bits: 8
INFO: OpenGL Z buffer depth bits: 24
INFO: OpenGL Double Buffer: 1
INFO: OpenGL Stencil buffer bits: 8
INFO: GLSL version: 4.60
Assertion failed: (dataSize > 0), function readStream, file common/stream.cpp, line 50.
Abort (core dumped)

Change History (5)

comment:1 by nix234, 4 months ago

Cc: nix234 added

comment:2 by nix234, 4 months ago

Priority: normalhigh

comment:3 by nix234, 4 months ago

Same error with Fedora36 an IntelGPU and ScummVM 2.5.1.

comment:4 by aquadran, 3 months ago

Summary: The Longest Journey crashes with Assertion failedSTARK: The Longest Journey crashes with Assertion failed

comment:5 by nix234, 7 weeks ago

Owner: set to nix234
Resolution: fixed
Status: newclosed

The german version of the game was corrupt. Work's as intended.

Note: See TracTickets for help on using tickets.