Opened 6 months ago

Closed 6 months ago

#13770 closed defect (invalid)

AGS: Resonance Null pointer referenced! on first screen on 2.6.0

Reported by: TiCoKH Owned by: TiCoKH
Priority: normal Component: Engine: AGS
Version: Keywords:
Cc: Game:

Description

In AGS engine/game Resonance GOG version after intro, game crash on first screen before player get control. Game close can't playable.

log:
User picked target 'resonance' (engine ID 'ags', game ID 'resonance')...

Looking for a plugin supporting this target... Adventure Game Studio

Running Resonance (GOG/English)
resonance.exe: 6cc23ce7cdf62de776c6b8ddb6b8a7ff, 850643390 bytes.
WARNING: TODO: SetCurrentDirectory: D:/Emulation/SCUMMvm/games/resonance/!
Initializing backend libs
Initializing game data
Opened game data file: game28.dta
Game data version: 50
Compiled with: 3.5.1.13
Startup directory: ./
Data directory: ./
Setting up game configuration
WARNING: FSNode::createDirectory: './.' already exists!
Voice pack found: speech.vox
Initializing TTF renderer
Initializing mouse: number of buttons reported is 3
Install timer
Initialize path finder library
Game title: 'Resonance'
Game GUI version: 119
Requested script API: v3.5.1 (8), compat level: v3.2.1 (0)
Lipsync data found and loaded
Plugin 'agsgalaxy' loaded as 'agsgalaxy.dll', resolving imports...
Checking for disk space
Game native resolution: 320 x 240 (32 bit)
Graphic settings: driver: OGL, windowed: no, screen size: 0 x 0, game scale: proportional
Requested graphics driver 'OGL' not found, will try existing drivers instead
WARNING: movement control not supported, mouse control can't be enabled!
Mouse speed control: disabled, unit: 1.000000, user value: 1.000000
Setting up window
Initialize sprites
Engine initialization complete
Starting game
WARNING: channel 2 - same clip assigned
!Error running function 'room_b':
Error (line 121): Null pointer referenced!
Debugger started, type 'exit' to return to the game.
Type 'help' to see a little list of commands and variables.
ERROR: !Error running function 'room_b':
Error (line 121): Null pointer referenced!
Read 4 history entries

Change History (7)

comment:1 by antoniou79, 6 months ago

I've tested on Windows 10 x64, with a recent development build of 2.7.0git and also the release build for 2.6.0 and I cannot reproduce the null pointer issue. I can watch the full intro and get to a controllable player mode, walk around and examine stuff around the apartment, or skip the intro and do the same. (there might be a minor overlay issue with the "60 hours earlier" message)

My log output is pretty much identical with yours up to (and including) the warning line:

WARNING: channel 2 - same clip assigned

MD5 hash and file size for resonance.exe match too.
The only line that is slightly different for me is

WARNING: FSNode::createDirectory: './//.' already exists!

comment:2 by tag2015, 6 months ago

I can't reproduce this either, I have the same setup (Win10, GOG version). Could you please tell us your OS version?

Also, could you please tell us the MD5 of the entire executable (the detector just uses a small part of it for speed reasons) ? If you can use a command prompt, you can do it directly using scummvm:

scummvm.exe --md5 --md5-path="[put your install directory here]\Resonance.exe"

Or you can use one of the many tools available online.

comment:3 by aquadran, 6 months ago

Summary: Resonance Null pointer referenced! on first screen on 2.6.0AGS: Resonance Null pointer referenced! on first screen on 2.6.0

comment:4 by TiCoKH, 6 months ago

Hi,
I checked on my old Win7 PC, issue is same.
But the command above is give different md5 than in a logs:

Microsoft Windows [Version 6.1.7601]

Copyright (c) 2009 Microsoft Corporation. All rights reserved.

D:\Emulation\SCUMMvm>scummvm.exe --md5 --md5-path="games\resonance\Resonance.exe
"
games/resonance/Resonance.exe: 7bbebe1e20d268df6b287e37b7cfada4, 850643390 bytes

comment:5 by tag2015, 6 months ago

I have the same md5 on my system (gog version 2.3), so it should be fine.

e:/gog games/resonance/resonance.exe: 7bbebe1e20d268df6b287e37b7cfada4, 850643390 bytes

Could you do the same for the audio.vox and speech.vox files, please? The checksums should be

e:/gog games/resonance/audio.vox: 1f454f61b9906c4ea0955f014582e4d5, 49934428 bytes
e:/gog games/resonance/speech.vox: 33451aceae09a3db3088bfbd19c7bed1, 211982190 bytes

comment:6 by TiCoKH, 6 months ago

Ok, is my mistake. audio.vox was missing from my directory.
Is strange engine just fail after game intro is finished, but if I test these from gog install not just from scummvm I should notice no music on title screen.

I close the ticket.

comment:7 by TiCoKH, 6 months ago

Owner: set to TiCoKH
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.