Opened 4 months ago

Last modified 2 months ago

#13768 pending defect (fixed)

STARK: TLJ no longer uses correct aspect ratio (stretched, widescreen bug/regression)

Reported by: huftis Owned by: ccawley2011
Priority: normal Component: Engine: Stark
Version: Keywords:
Cc: huftis Game: The Longest Journey

Description

In the game The Longest Journey, the correct aspect ratio is no longer used. Instead, the game is stretched to fill the width of the screen (i.e., to 16:9 in fullscreen mode). This happens in all parts of the game, but is perhaps easiest to see in the opening animation, where the FunCom logo now looks elliptical instead of circular.

This is an regression in Scummvm v2.6.0 (and still present in the latest Git version as of 2022-08-08). In v2.5.1, the correct aspect ratio was used (with black bars on the sides). Using git bisect, I found that the regression was introduced by this commit:

commit 60c73721989a7108540646118b43548b36ecc331 (HEAD, refs/bisect/bad)
Author: Cameron Cawley <ccawley2011@gmail.com>
Date:   Tue Apr 19 00:48:48 2022 +0100

    OPENGL3D: Make use of the active rect provided by WindowedGraphicsManager

I observe this bug on Linux (X11).

Change History (8)

comment:1 by huftis, 4 months ago

Component: --Unset--Engine: Stark
Summary: The Longest Journey no longer uses correct aspect ratio (stretched, widescreen bug/regression)STARK: TLJ no longer uses correct aspect ratio (stretched, widescreen bug/regression)

comment:2 by Alien-Grey, 3 months ago

This is also an issue with Windows 10.

The only way to make it run in the correct 4/3 aspect ratio is to use SDL Surface and 3D Renderer Software. But this is also not bug free because using Software as 3D Renderer has graphical glitches with this game.

Last edited 3 months ago by Alien-Grey (previous) (diff)

comment:3 by ccawley2011, 3 months ago

Does changing the stretch mode in the options fix the aspect ratio?

comment:4 by huftis, 3 months ago

No, changing the stretch mode has no effect (I have tried all the stretch modes).

comment:5 by ccawley2011, 3 months ago

Owner: set to ccawley2011
Resolution: fixed
Status: newpending

I've opened PR #4215 which should fix this.

comment:6 by i30817, 2 months ago

Sometimes, fullscreen stretching is a property of the graphics driver, not the software.

I remember clearly having to mess around with environment variables to get dosbox fullscreen to behave in linux x11 for example.

comment:7 by i30817, 2 months ago

If you're curious about the linux hack it's:

xrandr --output "$m" --set "scaling mode" "Full aspect"

comment:8 by i30817, 2 months ago

Or rather:

MONITORS=$(xrandr | grep " connected " | awk '{ print$1 }')
for m in "${MONITORS[@]}"; do

xrandr --output "$m" --set "scaling mode" "Full aspect"

done

to change all monitors, but you could do the same for the 'primary' in gnome by parsing the file '~/.config/monitors.xml' to find the primary monitor only (this file exists in both wayland and x11 for gnome, but i'm not quite sure wayland has this problem).

Note: See TracTickets for help on using tickets.