Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1375 closed defect

BS1: CD change crash

Reported by: SF/dsasuke Owned by: SF/ender
Priority: normal Component: Engine: Sword1
Keywords: Cc:
Game: Broken Sword 1

Description

When it says to insert cd2 i put it in.
Then i press a key to continue and it crashes

Ticket imported from: #871289. Ticket imported from: bugs/1375.

Change History (18)

comment:1 Changed 15 years ago by SF/khalek

Summary: Broken Sword crashBS1: CD change crash

comment:2 Changed 15 years ago by SF/khalek

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:3 Changed 15 years ago by SF/dsasuke

the version is 0.5.7cvs
it hapenes wen you end the first disc
The game is english
Version? dont know but it has voices
its on the pc win32
Sorry cant find a save game dont know how its named

comment:4 Changed 15 years ago by lavosspawn

please try again with current CVS, it should work now.
if it doesn't work please paste the error message(s) here.

comment:5 Changed 15 years ago by SF/dsasuke

i download todays daily build still dosent work =(
Sorry but i cant see the error scumVM just closes when i
insert cd2 and press key.

comment:6 Changed 15 years ago by lavosspawn

run it from a dos command line. This way you'll still see the
error message after it closes.

comment:7 Changed 15 years ago by SF/dsasuke

i tried runig from a dos command line but i cant use my save
game.
Why's that?

comment:8 Changed 15 years ago by fingolfin

Maybe try it once again with today's daily build (just in case that
when Lavosspawn wrote he put a fix in CVS, maybe he did it
briefly before posting that comment - in which case the daily build
you downloaded the same day wouldn't have the fix).

comment:9 Changed 15 years ago by SF/dsasuke

Still dosent work :(
Cant uderstand why if i have cd1 it just says wrong cd if put
cd2 it crashes.
Does that happen when you test it?

comment:10 Changed 15 years ago by SF/ender

We really can't do anything unless you tell us what error
is printed to the console when it DOES crash...

comment:11 Changed 15 years ago by SF/dsasuke

The only Problem is that i cant see the error before the
console crashes and in dos i cant load a saved game.
Then i guess my only option is star over the game from the
dos window right?
So that i can see the error...
So i m going to try that

comment:12 Changed 15 years ago by SF/ender

No, you simply have to run ScummVM from the directory with
the save game files in it from the dos window.

Apparantly you are double-clicking it from a different
location. Your savegame files must be in the same
directory as the one you start the program from in the dos
console.

comment:13 Changed 15 years ago by SF/kirschsaft

Hi,
I seem to have the same problem with BS1 (German) under
Linux. I use a CVS-ScummVM (ScummVM 0.5.7cvs (Jan 16 2004
17:41:01)
).
The game crashes after changing the CD with the message:
"Can't open cluster file scripts.CLU!"
This file doesn't seem to exist on CD2, but does on CD1.

comment:14 Changed 15 years ago by SF/dsasuke

kirschsaft
Thx For saying what the error is...
Since i have tried runnig from cmd to see the error.
Maybe now they can fix the prob and i can finaly finesh the
game =).
And thx to ScummVM team for all the help so far

comment:15 Changed 15 years ago by SF/dsasuke

In my previous post i mean i havent tried runnig from cmd
i dont know how to edit a post

comment:16 Changed 15 years ago by SF/khalek

Component: Engine: Sword1
Game: Broken Sword 1

comment:17 Changed 15 years ago by SF/ender

I'm closing this - basically, the way the CDs are laid out makes it
difficult to play directly from them at this time. We will investigate
alternative measures at a later time.

comment:18 Changed 15 years ago by SF/ender

Owner: set to SF/ender
Status: newclosed
Note: See TracTickets for help on using tickets.