Opened 2 years ago

Closed 23 months ago

Last modified 23 months ago

#13748 closed defect (fixed)

SCI: QfG3 - Stuck forever in the Laibon's hut

Reported by: lwcorp Owned by: sluicebox
Priority: normal Component: Engine: SCI
Version: Keywords:
Cc: Game: Quest for Glory 3

Description (last modified by lwcorp)

It seems the fix for #11425 unfortunately created 3 new issues:

1) If you enter with the horn, you can greet and tell about dinosaur, but not good bye. You're not supposed to leave anyway, but if you do want to, you simply can't.
2) If you enter only after leaving the horn in the chest storage, you can greet but not say good bye, meaning you're stuck there forever (I guess it's possible you'll eventually run out out of food and the game will be over).
3) Also, if you enter with the horn, you can ask about 2 different topics of Leopardmen which makes no sense, and each of them produces a different output.

Tested in ScummVM 2.7.0git1818-gc80da50f911 (Aug 2 2022 04:09:29)

Attachments (4)

qfg3.001 (65.9 KB ) - added by lwcorp 2 years ago.
Save game before entering the Laibon's hut with a horn for the first time. You can either immdiately enter or first leave the horn at the nearby storage chest
image-20220802-184856.png (53.9 KB ) - added by lwcorp 2 years ago.
If you immediately enter, you can't choose to leave
image-20220802-184923.png (58.0 KB ) - added by lwcorp 2 years ago.
If you enter only after leaving the horn out, you can't leave forever
image-20220802-185413.png (29.4 KB ) - added by lwcorp 2 years ago.
Leopardmen VS Leopardmen (2 different outputs)

Download all attachments as: .zip

Change History (7)

by lwcorp, 2 years ago

Attachment: qfg3.001 added

Save game before entering the Laibon's hut with a horn for the first time. You can either immdiately enter or first leave the horn at the nearby storage chest

by lwcorp, 2 years ago

Attachment: image-20220802-184856.png added

If you immediately enter, you can't choose to leave

by lwcorp, 2 years ago

Attachment: image-20220802-184923.png added

If you enter only after leaving the horn out, you can't leave forever

comment:1 by lwcorp, 2 years ago

Description: modified (diff)

by lwcorp, 2 years ago

Attachment: image-20220802-185413.png added

Leopardmen VS Leopardmen (2 different outputs)

comment:2 by sluicebox, 23 months ago

Owner: set to sluicebox
Resolution: fixed
Status: newclosed

Fixed in: https://github.com/scummvm/scummvm/commit/9bbdec165c3a3cb1009b9bd193ae968eaaa9048d

Thanks for testing this out; I want to make sure we've got this right for a couple reasons, one of them being that I don't plan on touching this game again. =)

You've reported three things. Number 3 is indeed a bug from the script patch; there are two Event 6 options that can now (sometimes) appear in Event 5. Great catch! The second "Leopardman" option and "Marriage" shouldn't appear in Event 5. I've updated the patch to fix that. They now behave as before and only appear during Event 6 before paying the bride's price.

Everything else though... sounds like you're unaware that you can just click Walk to exit the hut. =)

In other words: you can't say Good Bye because the game is programmed to not make that an option. That has nothing to do with the script patches, that's all original behavior, and none of it is a problem because you just give the horn or you walk away. (And in event 5, walking away automatically gives the horn.)

But if you didn't know that, I can see how not having Good Bye as an option would seem pretty bad. ;)

in reply to:  2 comment:3 by lwcorp, 23 months ago

Replying to sluicebox:

Fixed in: https://github.com/scummvm/scummvm/commit/9bbdec165c3a3cb1009b9bd193ae968eaaa9048d

Confirmed Number 3 seems fixed in the daily ScummVM 2.7.0git2430-g139536ced1a (Sep 3 2022 04:02:45), thanks!

Everything else though... sounds like you're unaware that you can just click Walk to exit the hut. =)

Well, you didn't mention it in #11425 so I assume until this fix you didn't know it either. :-)
Even if you did know, I didn't all this time, so I have to assume many others don't either...
Especially given that in any other event you're expected to say good bye to leave and there's not even a clear way out like a door or an opening.

You actually have to blindly click on various spots in the black border in the bottom until it lets you leave.
So I think it's worth it to add a simple "Good-bye" option to the "tell about" dialogue, is it hard?

Note: See TracTickets for help on using tickets.