#13744 closed defect (fixed)

WIN32: Wrong implicit icons path when no icons path is set in configuration file

Reported by: lotharsm Owned by: lotharsm
Priority: high Component: GUI
Version: Keywords:
Cc: Game:

Description

Currently, when no icons path is set in the configuration and ScummVM tries set the proper icons path by itself, it adds a "stray" ScummVM folder within the %APPDATA% directory.

Instead of %APPDATA%/ScummVM/Icons, it puts the files in %APPDATA%/ScummVM/ScummVM/Icons.

Since the wrong path is used not only for downloading the icon files, there's no visible error for the end user.

It does break the "Clear cache" functionality though, since the dummy files that are used to overwrite the current icons data are created as %APPDATA%/ScummVM/ScummVM/Iconsgui-icons-20211112.dat (note the missing / in "Iconsgui").

Tested with the current stable release 2.6.0 on Windows 11.

Change History (7)

comment:1 by lotharsm, 22 months ago

Looks like the issue is in the Win32 platform code itself, so other platforms are likely not affected.

comment:3 by lotharsm, 22 months ago

Backported to branch-2-6 as well, but could need more testing. We also need to verify other platforms are not affected.

comment:4 by lotharsm, 22 months ago

Cache clearing issue should be fixed with:

https://github.com/scummvm/scummvm/commit/1690f882ba070c9eda424654ee00b1c1f7b3f648

Tested on Win32 and on macOS (thanks a lot to criezy for helping me with this!), but it wouldn'T hurt if someone could validate the test results with an "empty" icons path and after setting one manually...

comment:5 by lotharsm, 22 months ago

Priority: blockerhigh

comment:6 by lotharsm, 21 months ago

Tested on Win32 and Linux by myself while criezy already confirmed macOS as working.

Closing.

comment:7 by lotharsm, 21 months ago

Owner: set to lotharsm
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.