Opened 2 months ago

Closed 8 weeks ago

#13733 closed defect (fixed)

DIRECTOR: Windows version of Spaceship Warlock has stopped working

Reported by: eriktorbjorn Owned by: mistydemeo
Priority: normal Component: Engine: Director
Version: Keywords:
Cc: Game: Spaceship Warlock

Description

My Windows version of Spaceship Warlock (1.1.3) has stopped working, both with the development version and the 2.6 branch. My Mac version (1.1.1/1.1.2) is still working, however.

The intro runs fine (except for the missing piece of music, see https://bugs.scummvm.org/ticket/12832), but when I try to start the actual game nothing happens. ScummVM prints the following warning:

WARNING: Movie stambul does not exist!

Bisecting points to the following commit as being the cause of the regression:

https://github.com/scummvm/scummvm/commit/1823539136a680e40153108542db4b8f3481e6ca

So I'm guessing it has something to do with the fact that there's a directory called "stambul" (if I change the name of it to upper-case, the warning message changes too). But there is in my Mac version as well, so I don't know.

Change History (2)

comment:1 by mistydemeo, 2 months ago

I've confirmed this happens to another game too, with an identical cause: a directory with the same basename as a movie. I have a patch for this, https://github.com/scummvm/scummvm/pull/4140, but I've asked Sev for feedback as the author of the original commit that added directories to the file filter in 1823539136a680e40153108542db4b8f3481e6ca.

comment:2 by mistydemeo, 8 weeks ago

Owner: set to mistydemeo
Resolution: fixed
Status: newclosed

I've merged the fix.

Note: See TracTickets for help on using tickets.