Opened 20 months ago

Closed 17 months ago

Last modified 17 months ago

#13729 closed defect (fixed)

AGS: Text display regression in Whispers of a Machine

Reported by: criezy Owned by: criezy
Priority: normal Component: Engine: AGS
Version: Keywords:
Cc: Game:

Description

Some text in Whispers of a Machine is displayed incorrectly. This can be see in the Load dialog (when starting a game if games were saved previously) where the text for the buttons is not aligned correctly. In the intro we can also see that the bottom part of the text is missing the outline.

This is a regression in upstream AGS and I created a bug report there already: https://github.com/adventuregamestudio/ags/issues/1742

The regression in ScummVM was introduced in commit https://github.com/scummvm/scummvm/commit/df29806aec

I am creating this ticket to track the issue in ScummVM, but the idea is to wait to see if and how it gets fixed upstream and possible back port that fix.

Attachments (1)

Screenshot from 2022-10-11 13-13-30.png (140.4 KB ) - added by i30817 17 months ago.
master 9f687ccf65fc92e69b05cbc44bddb4261b792bec

Download all attachments as: .zip

Change History (6)

comment:1 by i30817, 17 months ago

Did you happen to forget about this? It was completed (and also custom resolution issue this game had).

comment:2 by criezy, 17 months ago

Owner: set to criezy
Resolution: fixed
Status: newclosed

The upstream fix has now been merged in ScummVM and I confirmed that it works properly.

comment:3 by i30817, 17 months ago

Are you sure, because this is the result of building master here:

comment:4 by i30817, 17 months ago

Oh right this was another bug that was fixed on the game.

comment:5 by criezy, 17 months ago

Indeed. The screenshot you posted is related to a different bug (bug #12949) which is not yet fixed.
There has been so many issues with that game that it's difficult to keep track :-D

Note: See TracTickets for help on using tickets.