#13727 closed defect (fixed)

Blade Runner - Unable to locate page 2759 for animation frame 986 frame 0

Reported by: jjtt Owned by: antoniou79
Priority: normal Component: Engine: Bladerunner
Version: Keywords:
Cc: Game: Blade Runner

Description

I started playing the game on an Android tablet with the Play Store version of ScummVM (2.5.0) and encountered the error mentioned in the ticket summary.

# Steps to reproduce

  1. Load attached save game
  2. Talk to Crazylegs Larry
  3. Ask about Grigorian
  4. Arrest
  5. Error after two lines from McCoy

Also reproducible from an earlier save game

My game files match the md5 sums listed in the wiki (English, 4 cds) and I have the subtitles enabled.

Attachments (2)

Screenshot_20220719-203958_ScummVM.png (328.0 KB ) - added by jjtt 20 months ago.
bladerunner-win.012 (46.1 KB ) - added by jjtt 20 months ago.
Save game to reproduce

Download all attachments as: .zip

Change History (10)

by jjtt, 20 months ago

Attachment: bladerunner-win.012 added

Save game to reproduce

comment:1 by jjtt, 20 months ago

Reproduced on a PC also. Ubuntu 22.04, ScummVM 2.5.1

Looks like I'll have to play the good cop for now and not arrest Larry.

And patiently wait if someone has time to debug this.

comment:2 by jjtt, 20 months ago

The error looks very similar to the one in #10990, but that one seems to have been a case of wrong data files and mine do match the md5 hashes listed in the wiki here: https://wiki.scummvm.org/index.php?title=Blade_Runner#English_CD_release

comment:3 by antoniou79, 20 months ago

Hmm, I am unable to reproduce this in 2.7.0git (development version) nor 2.5.1 on Windows 10.

There *is* an unwanted bug that creeped here, the bug being that the clue required for this line of questioning (Grigorian and then arrest/let go option) should only be acquired in Restored Content mode, but it was added in vanilla mode too. Still I don't get the frame issue so far in vanilla mode nor in restored content mode.

I've checked on Android too, on the upcoming 2.6.0 so far. The error does not happen for me there either.

Do you have a rogue HDFRAMES.DAT file in your folder or are using the HDFRAMES method?
If not, can you recheck for the CDFRAMESx files specifically if they match the MD5 hashes and they have the same identical name as shown in the wiki page?

comment:4 by antoniou79, 20 months ago

Ah, never mind, I see the issue now.

When using the CDFRAMES files instead of the HDFRAMES.DAT, in vanilla mode only the required CDFRAMES file for the current Act is loaded, so the thing that is supposed to animate there is missing.

The bug does not happen in the Restored Content (where this is supposed to belong), because in this mode all the frame files are opened to use their resources regardless of the current game Act.

I've pushed a fix on development branch for the clue to be acquired only in Restored Content mode.
I'll see if I can also commit a fix for the case of people who happened to get the clue already so that the game won't crash there for them.

comment:5 by antoniou79, 20 months ago

I've pushed the second fix for the saved games in vanilla mode that have this problematic clue, in development branch (2.7.0git) and in the possible 2.6.1 bugfix release.

The workaround till then is one of these two:

  • Use HDFRAMES.DAT and not the separate CDFRAMESx.DAT files in your game's folder. Our wiki provides instructions on how to create an HDFRAMES.DAT file using ScummVM tools.
  • Don't arrest CrazyLegs.

Starting from 2.6.1 in a new playthrough the cuplrit clue (Grigorian's Resources) will only be possible to be acquired in Restored Content mode. Old saved games in vanilla mode will still work (and skip the problematic animation), but I'd recommend, if going through the path of arresting CrazyLegs, to do this in a Restored Content mode playthrough anyway.

comment:6 by antoniou79, 20 months ago

Owner: set to antoniou79
Resolution: fixed
Status: newpending

comment:7 by jjtt, 20 months ago

Thank you for fixing this. I'll arrest Crazylegs on the next playthrough :)

comment:8 by antoniou79, 19 months ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.