Opened 2 years ago

Closed 11 months ago

#13713 closed defect (fixed)

SCUMM/HE: Animation bug with Putt-Putt talking to Francine the Hippo

Reported by: Thunderforge Owned by: AndywinXp
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game: Putt-Putt Joins the Circus

Description (last modified by Thunderforge)

When Putt-Putt talks to Francine the Hippo for the first time, an animation bug occurs where his whole head disappears.

Reproduction Steps

  1. Load the attached save or use the debug console and type room 24
  2. Click on Francine the Hippo at the top of the high dive
  3. When the cutscene transitions to a close-up of Putt-Putt, his face will be fully visible, then his mouth will disappear, then the rest of this face.

See the attached screenshot and animated gif for a demonstration

Versions Tested

  • Putt-Putt Joins the Circus Steam version (US-English)
  • ScummVM 2.6.0pre 2022-07-09 for Windowx x64

Attachments (4)

puttcircus-win-us-PPCIRCUS.sg1 (31.2 KB ) - added by Thunderforge 2 years ago.
Animation Bug.gif (730.8 KB ) - added by Thunderforge 2 years ago.
scummvm-puttcircus-win-us-00000.png (1.5 MB ) - added by Thunderforge 2 years ago.
scummvm-puttcircus-win-us-00001.png (1.5 MB ) - added by Thunderforge 2 years ago.

Change History (12)

by Thunderforge, 2 years ago

by Thunderforge, 2 years ago

Attachment: Animation Bug.gif added

by Thunderforge, 2 years ago

by Thunderforge, 2 years ago

comment:1 by Thunderforge, 2 years ago

Turns out that this animation bug does *not* happen on ScummVM 2.1.0, the version bundled with the Steam release.

comment:2 by digitall, 2 years ago

FYI. Can not replicate on latest master i.e. ScummVM 2.7.0git1581-g8aeaabc6d17-dirty latest using my UK English CD version i.e. puttcircus-win-gb

So likely needs the US / Steam version to replicate.

comment:3 by Thunderforge, 2 years ago

Description: modified (diff)

comment:4 by Thunderforge, 2 years ago

Confirmed that it still happens on 2.7.0 Daily 2022-07-19 for Windows x64. So it's not a ScummVM version issue and most likely is indeed a game version issue.

Last edited 2 years ago by Thunderforge (previous) (diff)

comment:5 by Thunderforge, 2 years ago

Turns out that Steam also includes the UK version of the game. I tested with that version and indeed the issue does not happen in it.

So to confirm: this bug is unique to the English-US version (or at least the Steam release).

comment:6 by AndywinXp, 11 months ago

Hey, I have tested the original US CD version, and the UK and US versions from Steam, and I don't see the bug. Has this been fixed by some other side effect? Can anyone confirm?

comment:7 by AndywinXp, 11 months ago

Owner: set to AndywinXp
Resolution: fixed
Status: newpending

Hm... having double-checked with a 2.8.0git build *before* the sound engine rewrite, it seems that this bug has been fixed as a side effect of the audio changes. Still waiting for confirmation on Thunderforge end though.

comment:8 by Thunderforge, 11 months ago

Status: pendingclosed

Confirmed that the bug no longer occurs on the 2023-08-23 daily build. Thanks!

Note: See TracTickets for help on using tickets.