#13712 closed defect (fixed)

SCUMMVM displays totally corrupted graphics.

Reported by: carlo-bramini Owned by: carlo-bramini
Priority: normal Component: Video
Version: Keywords: OpenGL
Cc: Game:

Description (last modified by carlo-bramini)

I had an installation of SCUMMVM version 2.2.0 on my PC with Windows 11.
I uninstalled this one and then I installed the newer version 2.5.1.
Unfortunately, it displays corrupted graphics even when starting the GUI.
I reinstalled version 2.2.0 and it is working fine again.
I downloaded and tested also the candidate release 2.6.0 and it also shows corrupted graphics.
Next, I cloned the latest sources of the repository, I compiled them myself and I'm still getting wrong graphics.
But, if I configure with --opengl-mode=none, then the bug disappears.
I remember that in the past I got exactly the same issue with VICE emulator and it was caused by an error into the R/G/B/A masks.
I debugged for an hour this issue with VisualStudio, but unluckly I was not yet able to find the cause.
I hope that you could help me to find a solution. Thank you.

Sincerely.

Attachments (1)

scumm.png (50.9 KB ) - added by carlo-bramini 17 months ago.
The corrupted graphic output.

Download all attachments as: .zip

Change History (7)

by carlo-bramini, 17 months ago

Attachment: scumm.png added

The corrupted graphic output.

comment:1 by carlo-bramini, 17 months ago

Description: modified (diff)

comment:2 by carlo-bramini, 17 months ago

Description: modified (diff)

comment:3 by antoniou79, 16 months ago

Just for the record could you post your GPU model and current driver for it (if it's easy to find out)?

comment:4 by carlo-bramini, 16 months ago

Notebook Acer Nitro 5
NVIDIA GeForce GTX 1650 Ti
Driver GeForce 516.59

comment:5 by carlo-bramini, 15 months ago

After committing my PR posted here:

https://github.com/scummvm/scummvm/pull/4155

this issue has been resolved on my machine and it can be closed.

comment:6 by carlo-bramini, 15 months ago

Owner: set to carlo-bramini
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.