Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1367 closed defect (fixed)

FOTAQ no music

Reported by: SF/loki1985 Owned by: joostp
Priority: normal Component: Engine: Queen
Keywords: Cc:
Game: Flight of the Amazon Queen

Description

scummvm 0.5.7cvs win32
newest queen.tbl
fotaq german disk version

no music is played at all >:(

Ticket imported from: #868985. Ticket imported from: bugs/1367.

Change History (13)

comment:1 Changed 15 years ago by fingolfin

Assigning to joostp because he seems to have made queen/
music.cpp. ;-)
Joost, feel free to re- or un-assign as appropriate, you will know
better than me how to handle FOTAQ bugs.

comment:2 Changed 15 years ago by fingolfin

Owner: set to joostp

comment:3 Changed 15 years ago by eriktorbjorn

From what I can tell, FotAQ defaults to using AdLib music,
which isn't implemented yet. If I tell ScummVM to use a MIDI
music backend instead, I can hear music.

comment:4 Changed 15 years ago by joostp

I am not aware of FOTAQ deliberately defaulting to Adlib, it
requests a MDT_NATIVE midi driver and that should result in either
a Native MIDI driver, or NULL driver in case there is none (or when
-adlib was explicitly specified).

So, loki1985, the likely cause is that your system is either not
capable of (or not properly configured for) using Native MIDI OR
you are explicitly attempting to use the Adlib driver. (be it from
config file or command line). Could you please verify this?

Regardless, latest CVS will give you a warning if using Adlib was
attempted.

comment:5 Changed 15 years ago by joostp

apparently, adding adlib support was rather trivial, which means
that as of now there should be no reason to be not hearing any
music anymore.
I'd be interested to hear if your 'bug' still persists. (since it could
be a bug specific to the German version, for example)

comment:6 Changed 15 years ago by fingolfin

Pending response by bug submitter.

comment:7 Changed 15 years ago by fingolfin

Status: newpending

comment:8 Changed 15 years ago by SF/loki1985

will respond in next 3 days, got to test it. i'm not at home.
thanx for patience.

comment:9 Changed 15 years ago by SF/loki1985

Status: pendingnew

comment:10 Changed 15 years ago by SF/loki1985

works now (using latest CVS)!

next problem: at the beginning, the music gets 100% louder
for 1 second when seeing the clock in intro, and sounds
displaced.
i think that's not right. i'll test with original interpreter under
dosbox and see if different.

comment:11 Changed 15 years ago by joostp

File another bug report for the "next problem" if you deem it
necessary and have verified it doesn't occur in the original, but it
shouldn't go here.
I'm closing this, as the reported bug has been fixed.

comment:12 Changed 15 years ago by joostp

Resolution: fixed
Status: newclosed

comment:13 Changed 15 years ago by SF/khalek

Component: Engine: Queen
Game: Flight of the Amazon Queen
Note: See TracTickets for help on using tickets.