Opened 5 months ago

Closed 5 months ago

#13632 closed defect (fixed)

CHEWY: Talk with Nemoyan render game unplayable

Reported by: afreickmann Owned by: bluegr
Priority: high Component: Engine: Chewy
Version: Keywords:
Cc: Game: Chewy: ESC from F5

Description

When you talk to the Nemoyan, the dialogue window gets unresponsive. You still can load another savegame, but the dialogue will still show in your savegame and you can't interact with anything. Only restart of ScummVM solves the bug, until you reach the point again.
Problem with the dialogue seems to be only existing with activated speech. So this one can be very much a duplicate of #13594. But before I was able to always get around #13594 by early cut the text.

Attachments (3)

scummvm_nemoyan.png (53.5 KB ) - added by afreickmann 5 months ago.
chewy.007 (16.9 KB ) - added by afreickmann 5 months ago.
chewy.037 (21.2 KB ) - added by afreickmann 5 months ago.

Download all attachments as: .zip

Change History (8)

by afreickmann, 5 months ago

Attachment: scummvm_nemoyan.png added

by afreickmann, 5 months ago

Attachment: chewy.007 added

comment:1 by afreickmann, 5 months ago

Another scene where I get stuck forever is the parrot when choosing the Boo Boo Ba Baby option.

by afreickmann, 5 months ago

Attachment: chewy.037 added

comment:2 by bluegr, 5 months ago

Partially fixed with this commit
https://github.com/scummvm/scummvm/commit/9cd6e2750a05a0ba36feced10b8e51d0921ec78f

The dialog works now, but the dialog lines are not handled properly yet if they are not skipped and speech is enabled

comment:3 by lotharsm, 5 months ago

Priority: blockerhigh

comment:5 by bluegr, 5 months ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.