Opened 6 months ago

Closed 5 months ago

Last modified 5 months ago

#13629 closed defect (fixed)

ALL: ScummVM Audio options are broken

Reported by: afreickmann Owned by: bluegr
Priority: high Component: GUI
Version: Keywords:
Cc: Game:

Description

I tried to switch between subtitles, audio only and subtitles and speech and the options are not correctly saved in the ScummVM menu. Sometimes the change is anyway corrected applied, sometimes not. But in general, the audio option seems to be always locked to speech.
Eventually, I end up with NO speech and NO subtitles.

Get following Debug info:
WARNING: Wrong configuration: Both subtitles and speech are off. Assuming subtitles only!

Change History (4)

comment:1 by afreickmann, 6 months ago

It seems to be reproducable, if you are choosing the voices only option and then later try to switch to another option.

comment:2 by bluegr, 5 months ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed
Summary: CHEWY: ScummVM Audio options are brokenALL: ScummVM Audio options are broken

Thanks for reporting this! This was a recent regression in all engines, not just Chewy (thus, renaming the title to show this).

Fixed in the following commit:
https://github.com/scummvm/scummvm/commit/25401cdf922ca629d8e6c8d8664a07b0c755b897

Closing

comment:3 by bluegr, 5 months ago

Component: Engine: ChewyGUI

comment:4 by bluegr, 5 months ago

Game: Chewy: ESC from F5
Priority: normalhigh
Note: See TracTickets for help on using tickets.