#13608 closed defect (fixed)

CHEWY: Using Esc makes game unresponsive

Reported by: afreickmann Owned by: bluegr
Priority: normal Component: Engine: Chewy
Version: Keywords:
Cc: Game: Chewy: ESC from F5

Description

This one is harder to explain, but I assume its related to the hide mouse button when pressing Esc. The functionality of the action menu seems to work as expected, as hover highlight works. But you are not able to select the action to leave this menu. Also closing the action menu (after opening with right mouse button) will render the Interface unusable. Same effect can be reproduced in inventory.

Switching Fullscreen and Window mode or selecting via F-Keys is resetting the interface back to normal. So it's not a game breaker, but this has high potential to irritate users.

Change History (3)

comment:1 by dreammaster, 18 months ago

Ah, this is a good find. I'd seen similar issues when using the save dialog, but since that includes newly introduced code to open the ScummVM save/load dialogs, I wasn't sure if it wasn't that new code causing the problem. That it's reproducible using just "original" code may help the problem be identified more easily.

comment:2 by afreickmann, 18 months ago

Another scene where it was problematic: Pressing ESC at the probe mode selection screen on F5. I couldn't choose any option until I was able to free the button selection with above methods

comment:3 by bluegr, 17 months ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

Thanks for your report! Fixed in the following commit:
https://github.com/scummvm/scummvm/commit/2e3902fad051a5bbd107525d9558b8f167bf8ae6

Closing

Note: See TracTickets for help on using tickets.