Opened 4 months ago

Last modified 3 months ago

#13594 pending defect (fixed)

CHEWY: Dialog canceled by subtitles

Reported by: afreickmann Owned by: bluegr
Priority: high Component: Engine: Chewy
Version: Keywords:
Cc: Game: Chewy: ESC from F5

Description

When you have the text activated, all dialogs are getting skipped, IF you are not skipping the line earlier. Thus the game is near unplayable.
As a side effect, you will be stuck in a detail page (like in a 1:1 Dialog with Howard) in this case - which is a clear blocker.

The pure dialog version meanwhile is never finishing dialogs.

Attachments (2)

chewy.016 (19.3 KB ) - added by afreickmann 3 months ago.
chewy.043 (16.0 KB ) - added by afreickmann 3 months ago.

Download all attachments as: .zip

Change History (12)

comment:1 by afreickmann, 4 months ago

I guess, I know where it comes from. ;) The road to hell is paved with good intentions.

comment:2 by afreickmann, 4 months ago

Tested also with speech only, same behavior as the version text and speech.

comment:3 by afreickmann, 4 months ago

Was able to find build 1ffdbee4 from 13th noon, this one should not yet have fixes like 8df2859 (4pm CEST/2pm UTC). The build 60fdff42 from 17th has the same issues as i reported. So it should be unrelated to d81d6e5.

comment:4 by afreickmann, 3 months ago

I noticed that the dialog menu breaks all the time due to the bug, not just within the close ups.

comment:5 by lotharsm, 3 months ago

Priority: blockerhigh

comment:6 by bluegr, 3 months ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:7 by afreickmann, 3 months ago

Resolution: fixed
Status: closednew

Seems to be back, also in the master, not just the stable

comment:8 by bluegr, 3 months ago

Resolution: fixed
Status: newpending

Not sure why this has been reopened. I can't reproduce this. Please provide a saved game, or a way to reproduce.
Setting to pending

comment:9 by afreickmann, 3 months ago

OK, might be another bug, as now the dialogue is getting cut off in general after talking, if the line does not get skipped. I noticed it first in Big City, thus i attach the savegane 16 here. Talking with the paper boy still ends directly after line 1.

by afreickmann, 3 months ago

Attachment: chewy.016 added

by afreickmann, 3 months ago

Attachment: chewy.043 added

comment:10 by afreickmann, 3 months ago

Added another example: Savegame 43 is when getting the rejected script back, as the dialogue gets cancelled, the player will miss most likely all the information given during this dialogue.

Note: See TracTickets for help on using tickets.